gImageReader aggiornabile all'ultima versione (3.3.1)

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
gian_d
Linux 2.x
Linux 2.x
Messaggi: 351
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

gImageReader aggiornabile all'ultima versione (3.3.1)

Messaggio da gian_d »

Mi sono sbattuto per un paio di giorni per poter installare gImageReader su Plasma 5, ho appena visto che sul repository di Ponce lo slackbuild era stato nel frattempo aggiornato alla versione 3.0.1, però sono riuscito a adattare il vecchio slackbuild all'ultima versione rilasciata da Sandro Mani (manisandro), la 3.3.1 (in cui è stato peraltro rimosso definitivamente il supporto a Qt4). Ho lavorato con un po' di pazienza perché nel sorgente ci sono delle incompatibilità con la configurazione dell'installazione sulla Slackware di QuaZip (dalla current) e di Podofo (da slackbuild) e con l'applicazione di default della policy di CMake, oltre ad alcuni errori di compilazione per il mancato inserimento di un header di Qt in alcuni file del sorgente. Insomma ho dovuto lanciare la compilazione non so quante volte per intercettare questi "errori", riadattando di volta in volta le patch da applicare, ma alla fine ne sono venuto a capo. Peraltro, dopo l'installazione del dizionario aspell-it dalla extra della current ne è uscita fuori un'installazione pulitissima. Sia Tesseract sia gImageReader impostano automaticamente per default il dizionario per l'italiano (gImageReader lo ha applicato solo dopo l'installazione di aspell-it) e ho fatto la prova con una scansione, neppure un errore, azzeccati tutti i caratteri!

Per chi fosse interessato riporto nei post successivi tutti i passi da fare

1) Scaricare l'ultima versione di gImageReader: https://github.com/manisandro/gImageRea ... tag/v3.3.1

gian_d
Linux 2.x
Linux 2.x
Messaggi: 351
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Re: gImageReader aggiornabile all'ultima versione (3.3.1)

Messaggio da gian_d »

C'è un problema, il server non mi accetta post contenente codice. Un po' di pazienza e cerco di risolvere in altro modo

gian_d
Linux 2.x
Linux 2.x
Messaggi: 351
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Re: gImageReader aggiornabile all'ultima versione (3.3.1)

Messaggio da gian_d »

2) Predisporre le patch. Ne ho fatto una per correggere lo script CMakeLists.txt nella radice dei sorgenti e un'altra per correggere gli errori che la compilazione dava per due sorgenti.

La prima patch può essere scaricata da questo link: https://www.giand.it/download/CMakeLists.diff

La seconda patch da questo link: https://www.giand.it/download/HOCR-fix-QUrl.diff

3) Adattare il codice dello Slackbuild. Io ho lavorato sul codice del vecchio SlackBuild quello predisposto prima dell'aggiornamento sul repository. In sostanza bisogna passare "a mano" delle variabili a CMake per evitare conflitti nel rilevamento della libreria e dei file di inclusione di Podofo e di QuaZip. Si tratta di conflitti dovuti a nomi differenti applicati nelle installazioni di queste dipendenze. Peraltro il file di configurazione CMake di QuaZip deve essere un po' taroccato perchè lo script /usr/lib64/cmake/QuaZip-Qt5Config.cmake, pur essendo processato non rileva la versione di QuaZip perciò bisogna passare a CMake i percorsi agli header e alla libreria.
Non ho verificato se il codice dello slackbuild attualmente corrente si può utilizzare così com'è con pochi ritocchi, perciò riporto per intero lo slackbuild che ho utilizzato io (adattandolo dalla vecchia versione)

Può essere scaricato da questo link: https://www.giand.it/download/gimagereader.SlackBuild

gian_d
Linux 2.x
Linux 2.x
Messaggi: 351
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Re: gImageReader aggiornabile all'ultima versione (3.3.1)

Messaggio da gian_d »

A margine, non so quale sia il problema, forse ci sono delle impostazioni di sicurezza, ma il server mi rifiuta i post contenente codice. Prima me li rifiutava tutti, anche quelli delle patch, adesso mi rifiuta solo quello dello slackbuild.
Questo è il report:

Forbidden

You don't have permission to access this resource.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2804
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.11.2
Desktop: lxde
Località: Pisa
Contatta:

Re: gImageReader aggiornabile all'ultima versione (3.3.1)

Messaggio da ponce »

occhio che sul repository non ufficiale per current gimagereader e' aggiornato (ormai da una decina di giorni) allo snapshot dell'ultimo codice nel suo git, 20201201_2d32618, mentre la 3.3.1 e' del luglio 2019.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 351
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Re: gImageReader aggiornabile all'ultima versione (3.3.1)

Messaggio da gian_d »

ARRRGGGG!
Mi stai dicendo che mi sono arrovellato per due giorni a fare una cosa del tutto inutile visto che questi problemi erano già stati superati!? Da spararmi.
Comunque tutta esperienza che torna utile, questi tentativi mi permettono di conoscere meglio le dinamiche tra software, librerie e sistema operativo, è un modo di studiare. Senza considerare il fatto che dopo tanti anni sto iniziando a fare una cosa che ho sempre teorizzato, ovvero quello di modificare il codice. In qualche caso sono riuscito pure a personalizzare degli applicativi, cosa che non avrei mai immaginato di riuscire a fare.

Rispondi