Problemi pppoe

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
darkside04
Linux 2.x
Linux 2.x
Messaggi: 432
Iscritto il: mar 23 nov 2004, 0:00
Località: roma

Re: Problemi pppoe

Messaggio da darkside04 »

Gnomenetor ha scritto:Salve ragazzi,ho finalmente montato slack,il problema era dipeso dal fatto che IDE del hd si era rovinato,comunque,ora ho installata e una forza,ho letto un po' di guide al riguardo del protocollo pppoe e ho seguito ma nulla,come mai se do' pppoe-start mi chiude la connessione ?? e pure ho modificato #netconfig come statico,ho dato:

IP ADDRESS : 192.168.1.1
NETMASK:255.255.255.0
GATEWAY:192.168.1.2
NAMESERVER: nn so cosa mettere non l ho config..

Ho un modem eth0 Dlink DSL-302T,mi dite dove sbaglio please?
Grazie a tutti....
io la rete l'ho configurata come dhcp, dopodiche ho settato (http://192.168.1.1) il modem, un DSL-300T, in modalità router...sempre connesso (solo se hai una flat)
Gnomenetor ha scritto: si la scheda di rete mi e riconosciuta,e poi,nn ho detto di avere un router,ho un normale modem eth0....
c'è un opzione che ti fa scegliere tra modem e router..

ho inserito l'username e la password nei campi appositi (l'hai messe vero??) ed è quasi un anno e mezzo che è acceso ininterrottamente. Non ho fatto altro per connettermi!! :wink:
Gnomenetor ha scritto: o avevo conf netconfig,ora ho conf pppoe-setup ma nada,cioe',dando pppoe-start mi da connected! Solo che nn e vero,xche',quando apro un browse nn mi apre le pagine,come DNS primary ho dato 192.168.1.1 DNS secondary 192.168.1.2 ma nada... Ripeto si connette ma quando vado x aprire le pagine web mi risulta nn connesso...
il DNS primario non può essere 192.168.1.1 e il secondario 192.168.1.2 ....quelli sono l'indirizzo IP del modem e del computer i DNS primario e secondario te li fornisce chi ti da internet! tuttavia se setti la rete in modalità dhcp non è necessario impostare questi parametri.

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

caro gnomentor, prova a postare l'output di route dopo che hai dato pppoe-start...forse il problema può essere quello che indicava acrive; se invece provi a dare

Codice: Seleziona tutto

 lynx 66.102.9.147 
e appare google è un problema di dns

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

okkkkkkkkkkk

Messaggio da Gnomenetor »

Allora ragazzi grazie,mi sono copiati i DNS che usavo su debian,e ok...Paoletta dopo ho fatto il ping lynx 66.102.9.147 e uscito google,ma il pc si e connesso,e in linea..... :) si e connesso,ora mi compilo la rete WPN e sto da dio... Grazieeeeeeeeeee.......

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

uhm

Messaggio da Gnomenetor »

Ragazzi,solo che poi dopo,ho dato pppoe-stop sono andato x riconettermi ho dato pppoe-start e praticamente mi diceva connected ma in verita pingando mi diceve Unable connect tho host ...... Poi ho Riavviato la makkina ed ora son qui da slacky,e un problema di DNS vero ???

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

quando si verifica il problema controlla /etc/resolv.conf per sapere se è un problema di dns o no...

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

ok..

Messaggio da Gnomenetor »

ok paoletta gentilissima,grazie ragazzi,siete na fortza,da quanto che la volevo mettere slacky...... Finalmente... Grazie.... Vado a leggermi un botto de man... Quo si fatica :D

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

uhm...

Messaggio da Gnomenetor »

Uhm.. I problemi ricominciano...Dopo il riavvio ritento di collegarmi e nada,quindi il problema era evidentissimo dei DNS,allora accendo debian e la connetto,mi copio i DNS che genera automaticamente tramite pppoeconf e metto in /etc/resolv.conf di slacky,ovviamente la rete va alla grande,solo che una volta connesso i DNS ritornano a quelli di prima,quindi,io rifaccio dinuovo le conf correttamente (almeno credo) e do i DNS giusti sia a netconfig che a pppoe-setup,Ora i DNS sono giusti ma nn si collega piu'


root@tony:~# pppoe-start
. Connected!
root@tony:~# lynx 66.102.9.147

Looking up 66.102.9.147 first
Looking up 66.102.9.147
Making HTTP connection to 66.102.9.147
Alert!: Unable to connect to remote host.

lynx: Can't access startfile http://66.102.9.147/
root@tony:~#



Vi posto anche ifconfig -a


root@tony:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:13:8F:48:32:81
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:249 errors:0 dropped:0 overruns:0 frame:0
TX packets:219 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:28782 (28.1 Kb) TX bytes:33150 (32.3 Kb)
Interrupt:11 Base address:0xd400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:146 errors:0 dropped:0 overruns:0 frame:0
TX packets:146 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4234 (4.1 Kb) TX bytes:4234 (4.1 Kb)

ppp0 Link encap:Point-to-Point Protocol
inet addr:87.7.93.205 P-t-P:192.168.100.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:13 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:478 (478.0 b) TX bytes:37 (37.0 b)

root@tony:~#

Avatar utente
darkside04
Linux 2.x
Linux 2.x
Messaggi: 432
Iscritto il: mar 23 nov 2004, 0:00
Località: roma

Re: uhm...

Messaggio da darkside04 »

Gnomenetor ha scritto:
root@tony:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:13:8F:48:32:81
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:249 errors:0 dropped:0 overruns:0 frame:0
TX packets:219 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:28782 (28.1 Kb) TX bytes:33150 (32.3 Kb)
Interrupt:11 Base address:0xd400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:146 errors:0 dropped:0 overruns:0 frame:0
TX packets:146 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4234 (4.1 Kb) TX bytes:4234 (4.1 Kb)

ppp0 Link encap:Point-to-Point Protocol
inet addr:87.7.93.205 P-t-P:192.168.100.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:13 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:478 (478.0 b) TX bytes:37 (37.0 b)

root@tony:~#

Codice: Seleziona tutto

eth0      Link encap:Ethernet  HWaddr 00:04:76:A3:58:C2
          inet addr:151.51.117.189  Bcast:151.51.117.189  Mask:255.255.255.255
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:351401 errors:0 dropped:0 overruns:0 frame:0
          TX packets:386253 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:263649682 (251.4 Mb)  TX bytes:146589559 (139.7 Mb)
          Interrupt:5 Base address:0xc800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:328 (328.0 b)  TX bytes:328 (328.0 b)

torno a ripetere che secondo me hai i DNS sballati prova a ri-settare la rete, con netconfig, scegliendo, quando ti viene chiesto, la modalità DHCP in questo modo i DNS
saranno assegnati automaticamente (Sopra ti ho allegato il mio output di ifconfig).

Ciao. :wink:

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

uhm..

Messaggio da Gnomenetor »

si nn ce dubbio,sono i DNS ... Ma nn mi fungono nessuno... :( eppure ieri cio navigato alla stragrande... Qualcuono conosce qualke link dove trovare server DNS x alice????

Avatar utente
darkside04
Linux 2.x
Linux 2.x
Messaggi: 432
Iscritto il: mar 23 nov 2004, 0:00
Località: roma

Re: uhm..

Messaggio da darkside04 »

Gnomenetor ha scritto:si nn ce dubbio,sono i DNS ... Ma nn mi fungono nessuno... :( eppure ieri cio navigato alla stragrande... Qualcuono conosce qualke link dove trovare server DNS x alice????
DNS Primario: 212.216.112.112
DNS Secondario: 212.216.172.62

comunque se la rete è in modalità dhcp non serve impostare questi parametri.

Ciao.

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

uhm...

Messaggio da Gnomenetor »

allora io dico,visto che su debian uso il DHCP i server DNS me li genera da solo che in questo caso sono questi

Primary 85.37.17.58
Secondary 85.38.28.94

E nada,su slacky nn vanno,dark i tuoi server li provo da giorni,e nn ti posso negare che fino a ieri mi andavano,ma ora nada,allora mi sono creato un statico su debian,con questi server appunto e vanno alla grande,poi ho anche imparte provato questi http://www.katapekkia.net/dns_per_alice_adsl.html risultato su debian si,slacky no.... Il DHCP su slacky nn va,stessa cosa,allora mi inizio a porre questa domanda "SARA' VERAMENTE UN PROBLEMA DI DNS???"

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

Codice: Seleziona tutto

lynx 66.102.9.147 
se a pc connesso questo non va evidentemente non è un problema di dns;
quando fa così posta l'output di route -n

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

uhm...

Messaggio da Gnomenetor »

root@tony:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.100.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
root@tony:~#


E inutile nn va' piu' in rete :cry:

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

sì che ci va, con questi 2 comandi:

Codice: Seleziona tutto

 route del default 
 route add default dev ppp0

Avatar utente
Gnomenetor
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: sab 4 mar 2006, 14:06
Località: Taranto
Contatta:

risoltoooo

Messaggio da Gnomenetor »

hehhehe.il problema nn era li,ad un tratto mi sono ricordato di aver avuto in passato questa sofferenza su debian,nel route -n cera qualcosa di strano,che nn mi convinceva,ad un tratto il ricordo,risoluzione del problema ifconfig lo up

In questo modo viene fatto riconoscere indirizzo IP alla scheda di rete... hehehhe

Sono Onnnnnnnnn !!!! :)

Rispondi