Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
ciao,
ho dovuto a causa di una formattazione su hda cambiare la struttura dell'hard disk...........tutto ok parte perfettamente l'OS senza problemi.....l'unica cosa è che HTTPD non ha nessuna voglia di partire.....
per la precisione:
httpd: apr_sockaddr_info_get() failed for SERVER
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
presumo sia da cambiare qualche impostazione sul file di configurazione...ma quale???
oppure è il caso di reinstallarlo di sana pianta?
riotten ha scritto:ho riconfigurato il servername (mettendo Servername 192.168.0.1:80) ......adesso il servizio parte senza errori ma da LAN, HTTPD non è raggiungibile.
Bisognerebbe guardare le altre impostazioni.
Comunque io imposterei un HOSTNAME completo
per esempio server.example.com
in questo modo Apache dovrebbe prenderti il ServerName senza specificarlo esplicitamente. Lasciando la riga commentata insomma.
ciao, scusate se non ho risposto prima ma non ho avuto tempo....
ho modificato l'hostname ora è del tipo xxx.yyy.it
ma il problema si vede non è solo quello
root@SERVER:/home/nouser# httpd
httpd: apr_sockaddr_info_get() failed for xxx.yyy.IT
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Dopo mettilo pure nella direttiva ServerName in httpd.conf e modifica il file hosts, altrimenti non sa che ip ha il tuo hostname
Quell'errore che ti da è relativo al domain name, te lo dice chiaramente.
Il secondo invece ti indica che httpd non era in esecuzione, se invece lo era allora è un problema di permessi nel creare il file pid, oppure lo cerca dove non dovrebbe, oppure è finito lo spazio, etc...
Comunque ferma apache o con
#/etc/rc.d/rc.httpd stop
o con
apachectl stop
idem per avviarlo
Hai provato a disintallare il pacchetto e reinstallarlo?
riotten ha scritto:perfetto, ora httpd funziona perfettamente, ma ho lasciato commentata la riga ServerName in thhpd.conf....è il caso debba rimetterla?
Se trova il nome da solo no.
Quando è commentata Apache cerca di stabilire il nome della macchina. Se tutto è configurato solitamente ci riesce