HTTPD non parte.....dopo cambio struttura HD

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
riotten
Linux 1.x
Linux 1.x
Messaggi: 185
Iscritto il: mer 6 giu 2007, 16:05
Slackware: 13.37
Desktop: Fluxbox
Località: Udine

HTTPD non parte.....dopo cambio struttura HD

Messaggio da riotten »

ciao,
ho dovuto a causa di una formattazione su hda cambiare la struttura dell'hard disk...........tutto ok parte perfettamente l'OS senza problemi.....l'unica cosa è che HTTPD non ha nessuna voglia di partire.....
per la precisione:

Codice: Seleziona tutto

httpd: apr_sockaddr_info_get() failed for SERVER
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

presumo sia da cambiare qualche impostazione sul file di configurazione...ma quale???
oppure è il caso di reinstallarlo di sana pianta?

P.S: ho provato anche

Codice: Seleziona tutto

root@SERVER:/home/nouser# domainname 127.0.0.1
ma niente


ultima cosa è possibile che HTTPD succhi circa 100mb di ram?




.

Avatar utente
whites11
Linux 4.x
Linux 4.x
Messaggi: 1147
Iscritto il: ven 30 set 2005, 13:54
Località: Udine

Messaggio da whites11 »

servirebbe un output più prolisso.
prova a leggere i file in /var/log/apache

Avatar utente
riotten
Linux 1.x
Linux 1.x
Messaggi: 185
Iscritto il: mer 6 giu 2007, 16:05
Slackware: 13.37
Desktop: Fluxbox
Località: Udine

Messaggio da riotten »

vi posto gli ultimi 3giorni di error_log

Codice: Seleziona tutto

[Mon Nov 12 22:16:48 2007] [notice] Apache/2.2.4 (Unix) DAV/2 PHP/5.2.3 configured -- resuming normal operations
[Tue Nov 13 14:02:27 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:03:04 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:05:03 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Tue Nov 13 14:05:09 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:14:50 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:15:18 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Wed Nov 14 16:08:27 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Wed Nov 14 16:08:32 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Wed Nov 14 16:16:45 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Wed Nov 14 16:19:19 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Thu Nov 15 00:56:11 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Thu Nov 15 00:56:26 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Thu Nov 15 01:08:55 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Thu Nov 15 15:15:05 2007] [notice] caught SIGTERM, shutting down
[Thu Nov 15 15:22:50 2007] [alert] (EAI 3)Temporary failure in name resolution: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed
[Thu Nov 15 19:03:48 2007] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed
[Thu Nov 15 19:05:14 2007] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed
[Thu Nov 15 19:05:47 2007] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed


Avatar utente
whites11
Linux 4.x
Linux 4.x
Messaggi: 1147
Iscritto il: ven 30 set 2005, 13:54
Località: Udine

Messaggio da whites11 »

prova ad eseguire il comando

Codice: Seleziona tutto

hostname
cosa torna?

Avatar utente
riotten
Linux 1.x
Linux 1.x
Messaggi: 185
Iscritto il: mer 6 giu 2007, 16:05
Slackware: 13.37
Desktop: Fluxbox
Località: Udine

Messaggio da riotten »

Codice: Seleziona tutto

nouser@SERVER:~$ hostname
SERVER

Avatar utente
conraid
Staff
Staff
Messaggi: 13631
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Messaggio da conraid »

riotten ha scritto:

Codice: Seleziona tutto

nouser@SERVER:~$ hostname
SERVER
ServerName in httpd.conf come l'hai configurato?

Avatar utente
riotten
Linux 1.x
Linux 1.x
Messaggi: 185
Iscritto il: mer 6 giu 2007, 16:05
Slackware: 13.37
Desktop: Fluxbox
Località: Udine

Messaggio da riotten »

ho riconfigurato il servername (mettendo Servername 192.168.0.1:80) ......adesso il servizio parte senza errori ma da LAN, HTTPD non è raggiungibile.

Avatar utente
conraid
Staff
Staff
Messaggi: 13631
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Messaggio da conraid »

riotten ha scritto:ho riconfigurato il servername (mettendo Servername 192.168.0.1:80) ......adesso il servizio parte senza errori ma da LAN, HTTPD non è raggiungibile.
Bisognerebbe guardare le altre impostazioni.
Comunque io imposterei un HOSTNAME completo
per esempio server.example.com
in questo modo Apache dovrebbe prenderti il ServerName senza specificarlo esplicitamente. Lasciando la riga commentata insomma.

Naturalmente va modificato anche il file hosts

Avatar utente
riotten
Linux 1.x
Linux 1.x
Messaggi: 185
Iscritto il: mer 6 giu 2007, 16:05
Slackware: 13.37
Desktop: Fluxbox
Località: Udine

Messaggio da riotten »

ciao, scusate se non ho risposto prima ma non ho avuto tempo....
ho modificato l'hostname ora è del tipo xxx.yyy.it
ma il problema si vede non è solo quello

Codice: Seleziona tutto

root@SERVER:/home/nouser# httpd
httpd: apr_sockaddr_info_get() failed for xxx.yyy.IT
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
in più se lancio

Codice: Seleziona tutto

root@SERVER:/home/nouser# httpd -k stop
httpd (no pid file) not running
mi viene questo messaggio.....

qualche aiuto?

Avatar utente
conraid
Staff
Staff
Messaggi: 13631
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Messaggio da conraid »

Hai modificato l'hostname del pc?
se ora dai

Codice: Seleziona tutto

hostname -f
ti ritorna
xxx.yyy.it?

Dopo mettilo pure nella direttiva ServerName in httpd.conf e modifica il file hosts, altrimenti non sa che ip ha il tuo hostname

Quell'errore che ti da è relativo al domain name, te lo dice chiaramente.

Il secondo invece ti indica che httpd non era in esecuzione, se invece lo era allora è un problema di permessi nel creare il file pid, oppure lo cerca dove non dovrebbe, oppure è finito lo spazio, etc...

Comunque ferma apache o con
#/etc/rc.d/rc.httpd stop

o con

apachectl stop

idem per avviarlo

Hai provato a disintallare il pacchetto e reinstallarlo?

Avatar utente
riotten
Linux 1.x
Linux 1.x
Messaggi: 185
Iscritto il: mer 6 giu 2007, 16:05
Slackware: 13.37
Desktop: Fluxbox
Località: Udine

Messaggio da riotten »

perfetto, ora httpd funziona perfettamente, ma ho lasciato commentata la riga ServerName in thhpd.conf....è il caso debba rimetterla?

Avatar utente
conraid
Staff
Staff
Messaggi: 13631
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Messaggio da conraid »

riotten ha scritto:perfetto, ora httpd funziona perfettamente, ma ho lasciato commentata la riga ServerName in thhpd.conf....è il caso debba rimetterla?
Se trova il nome da solo no.
Quando è commentata Apache cerca di stabilire il nome della macchina. Se tutto è configurato solitamente ci riesce :-)

Rispondi