[Risolto] Gslap con avvio in init 4

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
prometeo79
Linux 4.x
Linux 4.x
Messaggi: 1278
Iscritto il: gio 17 mar 2005, 0:00
Slackware: 12
Località: Torino

[Risolto] Gslap con avvio in init 4

Messaggio da prometeo79 »

Ciao a tutti
Ho appena installato il bootsplash sul mio laptop e modificato inittab per l'avvio di X automatico.
Ora mi trovo col problema di non riuscire ad avviare gslapt, perchè se eseguo il comando da console dopo aver dato su ottengo:

Codice: Seleziona tutto

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(gslapt:1772): Gtk-WARNING **: cannot open display:


Perchè?
Altra questione sempre risuardante gslapt: come faccio ad avviarlo da X senza aprire la console? Non c'è un modo per far si che mi chieda la pw di root quando lo avvio?
Grazie
Ultima modifica di prometeo79 il sab 30 set 2006, 19:12, modificato 1 volta in totale.

Avatar utente
dapuzz
Linux 4.x
Linux 4.x
Messaggi: 1137
Iscritto il: mar 16 mag 2006, 11:09
Contatta:

Messaggio da dapuzz »

Hai una berllissima firma. Se cerchi l'errore lo trovi sicuramente.
comunque da console devi prima disabilitare il controllo per chi accede al serverX poi cambiare utente, impostare il display e lanciare il comando

Codice: Seleziona tutto

$ xhost +
access control disabled, clients can connect from any host
$ su
Password: **********
# DISPLAY=:0.0
# gslapt
O in alternativa kdesu gslapt (per kde)

Avatar utente
prometeo79
Linux 4.x
Linux 4.x
Messaggi: 1278
Iscritto il: gio 17 mar 2005, 0:00
Slackware: 12
Località: Torino

Messaggio da prometeo79 »

dapuzz ha scritto:Hai una berllissima firma. Se cerchi l'errore lo trovi sicuramente.
comunque da console devi prima disabilitare il controllo per chi accede al serverX poi cambiare utente, impostare il display e lanciare il comando

Codice: Seleziona tutto

$ xhost +
access control disabled, clients can connect from any host
$ su
Password: **********
# DISPLAY=:0.0
# gslapt
O in alternativa kdesu gslapt (per kde)
Ops...hai ragione! Cercavo per applicativo invece che per errore.
Sorry :?

Comunque problema risolto
Grazie

Rispondi