kernel panic unable to mount root in seguito riavvio forzato

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Bakkio2
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: gio 24 mar 2005, 0:00
Nome Cognome: Carlo B.
Slackware: 13.37 64
Kernel: 2.6.33.4-smp
Desktop: kde-4.4.3
Località: Villesse (GO)
Contatta:

kernel panic unable to mount root in seguito riavvio forzato

Messaggio da Bakkio2 »

Ieri sera stavo lavorando con la mia slack, quando ho mandato in crash il sistema...
Riavvio il sistema, e mentre lo stava caricando noto l'ora abbominevole (le 5 del mattino e non aggiungo altro)
Essendo nervoso per le ore di lavoro perse, ho spento il computer staccando direttamente la spina dal muro mentre stava finendo di ricaricare X11.
Poche ore più tardi (le 11 di questa mattina) trovo una bella sorpresa.
Quando avvio slak, parte lilo, e mi chiede se avviare win che si trova su hdd1 o slack che si trova su hda1.
Come il mio solito do un bel invio alla mia amata slack e dopo 3 secondi compare il messaggio.
Kernel panic, unable to mount root fs at 03:00......
Mentre il kernel si era fatto prendere dal panico, io rimango a nervi saldi e con una live cd provo a montare l'hard disk (mount -t ext3 /dev/hda1 /mnt/hda1), ma esce un simpatico messaggio d'errore dicendomi che il filesistem è errato o c'è un superblocco.
Sempre con i nervi saldi provo a dare fsck /dev/hda1 con il risultato di errore superblocco.......
provo con e2dfsck /dev/hda1 e mi da lo stesso errore....
A questo punto riavvio il computer con il dvd della slack e all'avvio do l'opzione bare.i root=/dev/hda1 noinitrd, ma succede come all'avvio normale, cioè tre secondi di schermata e parte la scritta panic error unable to mount etc etc....

arrivati alle 19:30 non solo il kernel si è fatto prendere dal panico, ma anche il titolare del pc...

Ditemi che riesco almeno a salvare i dati e i file di configurazione.......

Avatar utente
dapuzz
Linux 4.x
Linux 4.x
Messaggi: 1137
Iscritto il: mar 16 mag 2006, 11:09
Contatta:

Messaggio da dapuzz »

se non riesci a montare tu a mano, figuriamoci il kernel. Di sicuro sarà danneggiato il filesystem. Prova a vedere se recuperi qualcosa leggendo qui
http://www.astars.org/modules/xfsection ... ticleid=11

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar 30 nov 2004, 0:00

Messaggio da gohanz »

Non ho capito se il controllo del disco tu lo abbia fatto da una partizione montata o meno! Ovviamente non devi montare la partizione da controllare!
Poi ti riporto un link che servì a Samiel a suo tempo!

http://www.slacky.it/forum/viewtopic.ph ... 49&start=0

Avatar utente
Bakkio2
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: gio 24 mar 2005, 0:00
Nome Cognome: Carlo B.
Slackware: 13.37 64
Kernel: 2.6.33.4-smp
Desktop: kde-4.4.3
Località: Villesse (GO)
Contatta:

Messaggio da Bakkio2 »

inanzi tutto per rispondere a gohanz, il controllo del disco l'ho fatto a disco smontato, in quanto non riesco a montarlo.
Seconda cosa, sono andato a vedere il sito http://www.astars.org/modules/xfsection ... ticleid=11 e sono riuscito a vedere dove si trovano i backup del mio file system, ma adesso non ho capito come rimpostare un backup come filesystem attuale....

Avatar utente
Bakkio2
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: gio 24 mar 2005, 0:00
Nome Cognome: Carlo B.
Slackware: 13.37 64
Kernel: 2.6.33.4-smp
Desktop: kde-4.4.3
Località: Villesse (GO)
Contatta:

Messaggio da Bakkio2 »

oppure come faccio copiare un filesytem da un ardisk ad un altro???

Rispondi