Udev fa pasticci con i dischi [non risolvibile]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Udev fa pasticci con i dischi [non risolvibile]

Messaggio da Luci0 »

Ho installato la 12.0 su un Celeron 400 , mainboard chipset BX UDMA 33 funziona quasi tutto ma ho un fastidioso problema al boot ...
... il chipset del controller non viene riconosciuto correttamente e dal dmsg
vedo tutta una serie di errori e l' l ultradma viene disattivato ... inutile dire che se al termine del boot lo riattivo funziona tutto quanto ...
Ecco uno stralcio ...

Codice: Seleziona tutto

hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=39102336, sector=39102336
ide: failed opcode was: unknown
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=39102336, sector=39102336
ide: failed opcode was: unknown
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=39102336, sector=39102336
ide: failed opcode was: unknown
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x10 { SectorIdNotFound }, LBAsect=39102336, sector=39102336
Se disattivo udev tutto torna a posto ma ovviamente i driver del controller sono in modalità compatibile ... (modulo ata_generic) ma come lo rilancio riviene fuori questo pasticcio ... :-(
Ultima modifica di Luci0 il gio 2 ago 2007, 14:20, modificato 1 volta in totale.

Avatar utente
alessiodf
Linux 3.x
Linux 3.x
Messaggi: 823
Iscritto il: ven 14 ott 2005, 21:04
Slackware: current
Kernel: 2.6.26.4
Desktop: Kde 4.1
Località: Roma
Contatta:

Messaggio da alessiodf »

EDIT: leggendo qui (non avevo letto bene l'errore tuo) mi affretterei a fare un backup dei dati! hai un settore (il sector=39102336) che e' andato!
fonte: http://www.uwsg.indiana.edu/hypermail/l ... /0393.html

qui hanno risolto sembrerebbe!
http://www.linuxquestions.org/questions ... p?t=480669

in poche parole devi forzare il dma

Codice: Seleziona tutto

hdparm -Xudma0 /dev/hda
prova e facci sapere! ;)

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Ho fatto ricerche ... il disco testato con le utility della Seagate é ok ... il problema sembra essere che per qualche motivo la routine di attivazione dell' UDMA.
Cerco di spiegare ...
Il kernel ha un valore di LBA uguale a 39102336, letto dal firmware del disco e prima di attivare l'UDMA controlla se é vero cercando di leggere proprio l' ultimo settore , ma causa del valore errato il settore non esiste fisicamente, il test ritorna un errore e il kernel che fa il suo lavoro diligentemente lascia il disco in pio mode ...
Hdparm fa il suo lavoro senza controllare e funziona.
Sono affetti da questo bug i dischi della serie U5 Seagate (quelli con la gomma) qualcuno ha ipotizzato che dovrebbe essere sufficiente non fare partizioni fino alla fine del disco per risolvere il problema ... ma io ho fatto prima... l' ho sostituito perchè oltre ad essere incompatibile con linux é lento e rumoroso ... !!!

Ecco la fonte ... (c' é anche Alan Cox)
https://bugzilla.redhat.com/bugzilla/sh ... ?id=179564
Ultima modifica di Luci0 il gio 2 ago 2007, 13:04, modificato 1 volta in totale.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar 30 nov 2004, 0:00

Messaggio da gohanz »

Ho lo stesso tipo di errore, l'avevo anche con la 11.0 credo che sia da imputare ad un disco rigido mal funzionante! Spero di no! :roll:

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Ho riscritto il post precedente spero che sia più chiaro ...
Una soluzione potrebbe essere quella di riprogramme il firmware per far sì che il disco riporti un valore di LBA più basso, in tal modo il kernel riuscirebbe a leggere il settore ... forse nelle seatools c' é in utility ... per fare questo ... ora ci provo .... tanto ormai il disco l' ho clonato ...

Aggiornamento ... con le utility Seatools si può cambiare il valore LBA ... ma il kernel continua imperterrito a riportare lo stesso valore ... sembra non risolvibile a meno di un vero update del fimware dell' hard disk ...

Ecco quello che dice Alan Cox ...

I'm going to close this WONTFIX, simply because the required work to fix it in the old IDE layer is huge and would be risky. Realistically it won't happen. The SCSI core (used by libata) appears to already handle the odd sized media cases correctly.

Rispondi