[RISOLTO] Problema con phpmyadmin

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
madtux
Linux 1.x
Linux 1.x
Messaggi: 138
Iscritto il: ven 29 dic 2006, 20:34
Slackware: 13.1
Kernel: 2.6.33.4-smp
Desktop: xfce
Località: Castel di Sangro

[RISOLTO] Problema con phpmyadmin

Messaggio da madtux »

Ho un fastidioso problema con phpmyadmin,
quando ci accedo da
http://127.0.0.1/phpmyadmin
mi restituisce questo errore

Codice: Seleziona tutto

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.
Ho settato nel config.php il tipo di autenticazione, il percorso del phpmyadmin.
Ho anche googlato un po, da quel che ho capito phpmyadmin non sa dove salvare le sessioni.
Allora ho creato un directory apposta e messo nel php.ini il path della directory ma niente :evil: .
Idee :?:
Ultima modifica di madtux il mer 23 gen 2008, 13:33, modificato 1 volta in totale.

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4623
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 5.4.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: Problema con phpmyadmin

Messaggio da aschenaz »

A occhio e croce, il problema non sta nella configurazione di phpmyadmin, ma nel php stesso.

Hai provato a visualizzare il phpinfo?

Se non sai come fare, basta scrivere un file così

Codice: Seleziona tutto

<?php phpinfo() ?>
salvarlo con nome info.php (per esempio) e lanciarlo da browser con

Codice: Seleziona tutto

localhost/info.php

Avatar utente
madtux
Linux 1.x
Linux 1.x
Messaggi: 138
Iscritto il: ven 29 dic 2006, 20:34
Slackware: 13.1
Kernel: 2.6.33.4-smp
Desktop: xfce
Località: Castel di Sangro

Re: Problema con phpmyadmin

Messaggio da madtux »

Guarda ninobi il file phpinfo me lo visualizza senza problemi.
Ho anche decommentato la riga di sqlite nel php.ini visto che da shell mi dava errore.
Se non risolvo non posso usare mambo visto che ad ogni azione mi fa il logout.
Ho anche riscaricato l'ultima versione ma stessa situazione....
[-o< aiuto

Avatar utente
madtux
Linux 1.x
Linux 1.x
Messaggi: 138
Iscritto il: ven 29 dic 2006, 20:34
Slackware: 13.1
Kernel: 2.6.33.4-smp
Desktop: xfce
Località: Castel di Sangro

[RISOLTO] Problema con phpmyadmin

Messaggio da madtux »

Dopo aver scaricato l'ultima versione di phpmyadmin
ho modificato

Codice: Seleziona tutto

$cfg['Servers'][$i]['auth_type'] = 'cookie;
in

Codice: Seleziona tutto

$cfg['Servers'][$i]['auth_type'] = 'http';
e tutto funge.
La cosa più strana è che avevo fatto lo stesso anche con la precedente versione :roll:
Scusate per l'OT
Offtopic: Qualcuno sa dirmi perchè in mambo quando vado nella sezione di amministrazione,qualunque operazione/bottone fatta/premuto
mi viene fatto il logout???

Rispondi