Accesso Negato su HD

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
joepig
Linux 0.x
Linux 0.x
Messaggi: 5
Iscritto il: gio 3 apr 2008, 12:35

Accesso Negato su HD

Messaggio da joepig »

Salve, sono un nuovo utente del forum e colgo l'occasione per salutare tutti.

Vi pongo il mio problema:

dopo aver installato slackware 12.0 sul mio portatile (Toshiba) già dal primo avvio loggato come ROOT, quando provavo ad andare sulla partizione dove risiede il SO Linux mi restituiva l'errore
<<A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected
message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal")>>.

Dai vari forum ho letto che dovevo inserire l'account ROOT nel gruppo PLUGDEV. Dopo averlo fatto e riavviato il PC il problema è cambiato, quando infatti provo ad andare sulla partizione linux attraverso l'icona System sul desktop mi dà l'errore
<<Accesso Negato>> nonostante sia loggato come utente ROOT. Come posso risolvere questo problema? Vi ringrazio anticipatamente.

Avatar utente
neongen
Packager
Packager
Messaggi: 827
Iscritto il: ven 25 mag 2007, 12:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5
Contatta:

Re: Accesso Negato su HD

Messaggio da neongen »

non credo che hal possa mettere mano alla partizione in cui risiede il sistema (che poi è già montata)

joepig
Linux 0.x
Linux 0.x
Messaggi: 5
Iscritto il: gio 3 apr 2008, 12:35

Re: Accesso Negato su HD

Messaggio da joepig »

E allora cosa potrebbe essere?

Avatar utente
neongen
Packager
Packager
Messaggi: 827
Iscritto il: ven 25 mag 2007, 12:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5
Contatta:

Re: Accesso Negato su HD

Messaggio da neongen »

:D
appunto quello che ho scritto. la partizione è già montata e hal non la deve toccare!
se vuoi vederne il contenuto metti "/" al posto di "system:/media/hda1" nella barra indirizzo :thumbright: e poi leggi
http://www.slacky.eu/s4d/S4d.pdf

joepig
Linux 0.x
Linux 0.x
Messaggi: 5
Iscritto il: gio 3 apr 2008, 12:35

Re: Accesso Negato su HD

Messaggio da joepig »

Si così funziona, già avevo provato. Io però mi chiedevo come poterla farla montare in system:/media/sda1 (perché a me lo monta qui) senza avere errori.

Grazie per la guida pdf

Avatar utente
Blizzard
Master
Master
Messaggi: 1509
Iscritto il: mar 2 gen 2007, 22:53
Nome Cognome: Giovanni Santostefano
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: Fluxbox
Contatta:

Re: Accesso Negato su HD

Messaggio da Blizzard »

Ciao,
come dice il messaggio di errore, si tratta di una politica di sicurezza. Anche se inserisci una chiavetta non riuscirai a montarla in quel modo da root ma dovrai utilizzare il canonico mount (o smanettamente vari, non so!)
Il consiglio che posso darti e di creare un utente ed utilizzare il sistema da utente.
Non solo potrai fare tutto quello che ti pare (come automount di media ecc...) ma ti risparmierai parecchi grattacapi e reinstallazioni se metti mano a qualcosa cui non dovresti.
Usa root solo per amministrazione e possibilmente da console.

ciao
Gio

Avatar utente
anycolouryoulike
Packager
Packager
Messaggi: 1158
Iscritto il: ven 10 ago 2007, 0:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

Re: Accesso Negato su HD

Messaggio da anycolouryoulike »

Blizzard ha scritto:Ciao,
come dice il messaggio di errore, si tratta di una politica di sicurezza. Anche se inserisci una chiavetta non riuscirai a montarla in quel modo da root ma dovrai utilizzare il canonico mount (o smanettamente vari, non so!)
Il consiglio che posso darti e di creare un utente ed utilizzare il sistema da utente.
Non solo potrai fare tutto quello che ti pare (come automount di media ecc...) ma ti risparmierai parecchi grattacapi e reinstallazioni se metti mano a qualcosa cui non dovresti.
Usa root solo per amministrazione e possibilmente da console.

ciao
Gio
Da utente è la stessa storia...
Io avevo risolto come dice questo topic viewtopic.php?p=149260, ossia crei /etc/udev/rules.d/10-ale.rules e ci metti dentro questo:

Codice: Seleziona tutto

KERNEL=="hda1", SYMLINK+="root"

joepig
Linux 0.x
Linux 0.x
Messaggi: 5
Iscritto il: gio 3 apr 2008, 12:35

Re: Accesso Negato su HD

Messaggio da joepig »

Hai ragione anycolouryoulike, con un altro utente è la stessa storia.

Stasera quando torno a casa proverò la tua soluzione e vi farò sapere!

Intanto grazie.

Avatar utente
danix
Staff
Staff
Messaggi: 3289
Iscritto il: ven 27 ott 2006, 19:32
Nome Cognome: Danilo M.
Slackware: 64 current
Kernel: 6.12.13 x86_64
Desktop: i3
Località: Verona (VR)
Contatta:

Re: Accesso Negato su HD

Messaggio da danix »

basta aggiungere i vari utenti che vuoi abbiano accesso al device al gruppo plugdev e riavviare, in questo modo avrai accesso a tutti i device collegati e montati nel pc, per quanto riguarda il problema di hal che non visualizza la partizione di sistema è un problema già trattato ampiamente nella discussione che ti ha postato anycolouryoulike, anche se, a mio avviso non è un grosso problema non vedere montata 2 volte la partizione / :D , anche se non credo ci siano problemi, probabilmente la mia è più che altro pignoleria...

Ciau...
danix
danix ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

joepig
Linux 0.x
Linux 0.x
Messaggi: 5
Iscritto il: gio 3 apr 2008, 12:35

Re: Accesso Negato su HD

Messaggio da joepig »

Ho provato come mi ha suggerito anycolouryoulike.

Funziona benissimo. Grazie tanto ragazzi. Grazie a tutti.

Questo si che è un forum come si deve!!!!

Rispondi