Non riesco a montare le pendrive

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Non riesco a montare le pendrive

Messaggio da gian_d »

È la prima volta che mi succede quindi ho il sospetto che ci possa essere qualche problema dai nuovi kernel, anche se ci credo poco.
Comunque, poco fa dovevo trasferire dei file su una pendrive formattata in NTFS perché la uso per trasferire questi file su sistemi windows quando sono a scuola. Infilo la pendrive mi compare la notifica su KDE e come di consueto clicco su "Apri con il gestore dei file".
Risultato: Impossibile montare il seguente dispositivo: bigpen (è l'etichetta di volume della pendrive)

Ho provato ad aggirare ricorrendo a fstab e ho aggiunto la seguente riga:

Codice: Seleziona tutto

UUID=511D1CA778DA2B4D                     /pendrive         nfts   defaults            0 0
poi ho provato a montare la pendrive da root e mi restituisce questo messaggio:

Codice: Seleziona tutto

mount: /pendrive: unknown filesystem type 'ntfs'
Pensando che fosse un problema di modulo non caricato ho provato lanciando modprobe ntfs, il modulo viene caricato perché poi risulta in

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

ops... ho premuto per errore enter. Continuo qui
risulta in /proc/filesystems (insieme peraltro a fuse).
Niente da fare.
Provato a fare il boot con il kernel huge, stesso problema
Naturalmente sono installati sia i pacchetti fuse* sia ntfs-3g (o come si chiama, non ricordo)

A questo punto mi sono tolto il dubbio di provare con altre due pendrive in cui sono caricate delle ISO di installazione della slackware. Nessuna di queste viene montata attraverso KDE.
Da cosa può dipendere? Adesso non ricordo quando ho usato per l'ultima volta la pendrive in NTFS su questo sistema, non escludo che non l'abbia mai usata da quando ho reinstallato ex novo la current, però sono sicuro di aver usato almeno una delle due pendrive contenenti le ISO perché l'avevo usata per installare una current in virtualbox circa un mesetto fa.

Nel frattempo non ho fatto modifiche significative sulla configurazione del sistema a parte queste:
1) aggiornamento dei kernel (attualmente il kernel 5.4.11) oltre ai pacchetti rilasciati via via sulla current
2) passaggio al kernel generic (in ogni caso il problema c'è anche su huge)

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

Per ora ho temporaneamente "risolto" trasferendo tutti i file in un archivio compresso che poi ho scaricato da un portatile in cui ho una slackware 14.2 e da qui trasferito sulla pendrive. Ma in ogni caso il problema

Aggiungo un'altra cosa: una delle pendrive con la iso l'ho usata pochi giorni fa per fare il boot quando stavo cercando di ripristinare grub, quindi è certo che le pendrive non sono taroccate, perché funzionano regolarmente in altri contesti.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6564
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Non riesco a montare le pendrive

Messaggio da targzeta »

Quando inserisci una pendrive, il kernel la riconosce e crea un dev col nome /dev/sdXY. Il comando dmesg dovrebbe "dirti" qualcosa in merito.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

Ancora: ho fatto il login grafico come root per avviare gparted perché dall'utenza normale non riuscivo a farlo per non so quale errore.
Gparted riconosce entrambe le chiavette, sia quella in NTFS sia la iso. Peraltro da gparted ho montato la chiavetta in ntfs anche se comunque il gestore dei file non riesce ad aprirla neppure con root. Invece, sempre in ambiente grafico, come root apro e accedo al contenuto della pendrive contenente la iso.

A questo non ci capisco più nulla: le interfacce USB funzionano, quindi è probabilmente un problema di filesystem e/o di permessi. Ma non capisco perché tutto questo sia capitato all'improvviso senza che abbia modificato la configurazione!

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

targzeta ha scritto:Quando inserisci una pendrive, il kernel la riconosce e crea un dev col nome /dev/sdXY. Il comando dmesg dovrebbe "dirti" qualcosa in merito.

Emanuele
Devo riavviare il sistema perché da dmesg non si capisce quale delle due pendrive è rilevata, voglio azzerare tutto per sincerarmi

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6564
Iscritto il: gio 3 nov 2005, 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Non riesco a montare le pendrive

Messaggio da targzeta »

dmesg -c cancella la history, quindi rimetti la pennina e vedi cosa ti dice il kernel.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

Va be', abbi pazienza con un povero pirla che ignora parecchie cose :-D

Codice: Seleziona tutto

[  179.903583] usb 3-1: new high-speed USB device number 2 using ehci-pci
[  179.919591] usb 3-1: New USB device found, idVendor=18a5, idProduct=0302, bcdDevice= 1.00
[  179.919596] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  179.919599] usb 3-1: Product: STORE N GO                    
[  179.919602] usb 3-1: Manufacturer: Verbatim                      
[  179.919604] usb 3-1: SerialNumber: 120300000000176B
[  179.965916] usb-storage 3-1:1.0: USB Mass Storage device detected
[  179.966150] scsi host5: usb-storage 3-1:1.0
[  179.966309] usbcore: registered new interface driver usb-storage
[  179.971897] usbcore: registered new interface driver uas
[  181.006368] scsi 5:0:0:0: Direct-Access     Verbatim STORE N GO       1.01 PQ: 0 ANSI: 2
[  181.007530] sd 5:0:0:0: [sde] 31299584 512-byte logical blocks: (16.0 GB/14.9 GiB)
[  181.008215] sd 5:0:0:0: [sde] Write Protect is off
[  181.008219] sd 5:0:0:0: [sde] Mode Sense: 03 00 00 00
[  181.008861] sd 5:0:0:0: [sde] No Caching mode page found
[  181.008865] sd 5:0:0:0: [sde] Assuming drive cache: write through
[  181.026330] sd 5:0:0:0: [sde] Attached SCSI removable disk
Oltre a questo mi compaiono (però prima di montare) dei messaggi di errore che mi preoccupano non poco, ma forse non c'entrano:

Codice: Seleziona tutto

[   27.971643] caller _nv000906rm+0x1bf/0x1f0 [nvidia] mapping multiple BARs
[   44.392364] traps: upowerd[1745] trap int3 ip:7fe4590c6855 sp:7ffd00fd6ed0 error:0 in libglib-2.0.so.0.6200.4[7fe45908e000+7d000]
[   44.514947] traps: upowerd[1762] trap int3 ip:7f35294d6855 sp:7fffc9b94be0 error:0 in libglib-2.0.so.0.6200.4[7f352949e000+7d000]
[   44.850031] traps: upowerd[1777] trap int3 ip:7f02239d6855 sp:7fff46ceb570 error:0 in libglib-2.0.so.0.6200.4[7f022399e000+7d000]
[   44.863707] traps: upowerd[1783] trap int3 ip:7fc64799e855 sp:7fff42fae1a0 error:0 in libglib-2.0.so.0.6200.4[7fc647966000+7d000]
[   47.073013] traps: upowerd[1808] trap int3 ip:7f808d4a6855 sp:7ffc079d9cb0 error:0 in libglib-2.0.so.0.6200.4[7f808d46e000+7d000]
[   47.093113] traps: upowerd[1814] trap int3 ip:7ff9d3c76855 sp:7ffcd4ef9960 error:0 in libglib-2.0.so.0.6200.4[7ff9d3c3e000+7d000]
[   47.109600] traps: upowerd[1820] trap int3 ip:7fe247196855 sp:7ffdb2d94100 error:0 in libglib-2.0.so.0.6200.4[7fe24715e000+7d000]
[   47.123393] traps: upowerd[1826] trap int3 ip:7fd83abbe855 sp:7ffe0bbe7010 error:0 in libglib-2.0.so.0.6200.4[7fd83ab86000+7d000]
[   47.137170] traps: upowerd[1832] trap int3 ip:7f9b4415e855 sp:7ffe2abd7a10 error:0 in libglib-2.0.so.0.6200.4[7f9b44126000+7d000]
[   47.153153] traps: upowerd[1838] trap int3 ip:7f85f4ba6855 sp:7ffe5934c8f0 error:0 in libglib-2.0.so.0.6200.4[7f85f4b6e000+7d000]
[   52.817003] show_signal: 3 callbacks suppressed
[   52.817005] traps: upowerd[1985] trap int3 ip:7f14c2fd6855 sp:7fffef214ae0 error:0 in libglib-2.0.so.0.6200.4[7f14c2f9e000+7d000]
[   52.871645] traps: upowerd[1993] trap int3 ip:7f0c4cfb6855 sp:7ffda2a59df0 error:0 in libglib-2.0.so.0.6200.4[7f0c4cf7e000+7d000]
[   57.898822] traps: upowerd[2068] trap int3 ip:7f3c8327e855 sp:7ffd16dc8d40 error:0 in libglib-2.0.so.0.6200.4[7f3c83246000+7d000]
[   57.960724] traps: upowerd[2075] trap int3 ip:7fe4343b6855 sp:7ffd0237a000 error:0 in libglib-2.0.so.0.6200.4[7fe43437e000+7d000]
[   58.627776] fuse: init (API version 7.31)
[   58.627825] *** VALIDATE fuse ***
[   58.627831] *** VALIDATE fuse ***
[   60.231959] traps: upowerd[2122] trap int3 ip:7fce49956855 sp:7fff4c463a70 error:0 in libglib-2.0.so.0.6200.4[7fce4991e000+7d000]
[   60.257064] traps: upowerd[2128] trap int3 ip:7f9f3d23e855 sp:7ffeaaa2b830 error:0 in libglib-2.0.so.0.6200.4[7f9f3d206000+7d000]

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

Adesso c'è caricato l'huge. Apparentemente mi sembra che l'interfaccia USB non dia problemi, a parte quel "No Caching mode page found", che forse è irrilevante.

Quei messaggi di errore mi viene il sospetto che dipendano dal driver nvidia, anche se poi il driver funziona regolarmente.

fuse mi sembra essere attivo.

Ergo, non ci capisco una mazza, forse è meglio che stacchi e mi guardi un film, non è giornata...

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

Per ultimo, la pendrive contenente la ISO viene rilevata così:

Codice: Seleziona tutto

[  942.311637] usb 3-1: new high-speed USB device number 5 using ehci-pci
[  942.328730] usb 3-1: New USB device found, idVendor=18a5, idProduct=0302, bcdDevice=11.00
[  942.328735] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  942.328738] usb 3-1: Product: STORE N GO
[  942.328740] usb 3-1: Manufacturer: Verbatim
[  942.328743] usb 3-1: SerialNumber: 0138000000002566
[  942.329207] usb-storage 3-1:1.0: USB Mass Storage device detected
[  942.329432] scsi host5: usb-storage 3-1:1.0
[  943.733477] scsi 5:0:0:0: Direct-Access     Verbatim STORE N GO       1100 PQ: 0 ANSI: 4
[  943.736069] sd 5:0:0:0: [sde] 30515200 512-byte logical blocks: (15.6 GB/14.6 GiB)
[  943.737192] sd 5:0:0:0: [sde] Write Protect is off
[  943.737196] sd 5:0:0:0: [sde] Mode Sense: 43 00 00 00
[  943.738326] sd 5:0:0:0: [sde] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[  943.754524]  sde: sde1 sde2
[  943.761581] sd 5:0:0:0: [sde] Attached SCSI removable disk

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

Allora, il problema è probabilmente più serio di quanto sembrasse perché credo di avere il sistema un po' incasinato nella configurazione. Si tratta sicuramente di una questione di autorizzazioni che ha a che fare con polkit. Mi è venuto il sospetto perché non riesco più ad avviare gparted da un'utenza normale, il sistema non mi chiede l'inserimento della password di root: lanciando gparted da riga di comando compare questo avviso:

Codice: Seleziona tutto

Error getting authority: Error initializing authority: Error calling StartServiceByName for org.freedesktop.PolicyKit1: Launch helper exited with unknown return code 127
Detto questo ho spulciato più attentamente e ho visto che nelle notifiche di KDE, quando avvisa della mancata apertura della pendrive, compare un piccolissimo link che fa apparire questo messaggio:

Codice: Seleziona tutto

You are not authorized to perform this operation: 
Not authorized to perform operation (polkit authority not available and caller is not uid 0)
Questo problema salta fuori anche con una nuova utenza appena creata. Quindi non è generato dalla configurazione dell'utente bensì dalla configurazione del sistema.

Indagando ulteriormente, ho constatato che da root riesco ora ad aprire la pendrive formattata in NTFS (strano perché ieri non riuscivo ad aprirla neppure come root).

Ho provato a reinstallare polkit ma non cambia nulla. Sicuramente ho combinato qualche pasticcio modificando delle impostazioni per provare a risolvere altri problemi, ma non so assolutamente dove andare a parare. Non escludo di aver fatto qualche cavolata clonando parte della configurazione da una precedente installazione: spesso per praticità copio e incollo file di configurazione da /etc di altre installazioni. Quando ho cambiato i dischi ho copiato parecchio dalla vecchia installazione della current.

A questo punto credo che forse sia il caso di reinstallare il sistema e impostare una configurazione pulita (sigh)

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3261
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Non riesco a montare le pendrive

Messaggio da joe »

Due suggerimenti al volo:
- se in un terminale lanci "tailf /var/log/messages" e poi attacchi la chiavetta vedi "in diretta" come la riconosce il kernel (in particolare il nome del dispositivo, che dal dmesg sopra dovrebbe essere /dev/sde)
- riporta sempre un "fdisk -l" del dispositivo, in questo caso "fdisk -l /dev/sde", così chi legge vede com'è partizionato ecc
- prova a montare la partizione anche a mano lasciando perdere un attimo fstab "mount /dev/sde1 /mnt/cartellachevuoi", se è ntfs dovrai aggiungere se ricordo bene l'opzione "-t ntfs-3g" al comando mount.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

la pendrive viene riconosciuta regolarmente e anche il filesystem, infatti fa il mount diretto in ambiente grafico da root. Penso che lo faccia anche da fstab, come tipo di filesystem mettevo ntfs ma adesso mi fai pensare che avrei dovuto mettere ntfs-3g.

In ogni modo ho deciso di fare una reinstallazione pulita, ho troppi casini nella configurazione, con dmesg saltano fuori diversi errori di configurazione, quello del mount della pendrive è solo un problema collaterale. Adesso ho fatto il backup ora mi scarico l'iso dell'ultima current e poi installo. È la cosa più ragionevole invece di cercare di mettere delle toppe che nascondono i problemi invece di risolverli.

Avatar utente
conraid
Staff
Staff
Messaggi: 13488
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da conraid »

Domanda banale, e ti chiedo scusa se la faccio, ma... hai aggiunto l'utente a tutti i gruppi consigliati vero?

gian_d
Linux 2.x
Linux 2.x
Messaggi: 273
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Non riesco a montare le pendrive

Messaggio da gian_d »

oltre al gruppo proprio fa parte dei gruppi disk, audio, cdrom, video, pulse, plugdev, sshd, power, scanner, burning, vboxusers
Non so se ne manca qualcuno, ma di solito io aggiungo questi gruppi

Rispondi