[RISOLTO]mame e libSDL2-2.0.so.0

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
shellx
Linux 0.x
Linux 0.x
Messaggi: 17
Iscritto il: mer 12 ott 2016, 23:38
Slackware: 14.2 (64bit)
Kernel: 4.4.14
Desktop: Fluxbox
Contatta:

[RISOLTO]mame e libSDL2-2.0.so.0

Messaggio da shellx »

Salve a tutti, ne approfitto per avere un altro supporto ad un altro mio problema

ho installato il mame nella mia slackware 14.2 64bit

Codice: Seleziona tutto

root@slack:~# installpkg mame-0.217-i686-1cbz.txz 
Verifying package mame-0.217-i686-1cbz.txz.
Installing package mame-0.217-i686-1cbz.txz:
PACKAGE DESCRIPTION:
# MAME is a multi-purpose emulation framework.
#
# MAME's purpose is to preserve decades of software history. As
# electronic technology continues to rush forward, MAME prevents this
# important "vintage" software from being lost and forgotten. This is
# achieved by documenting the hardware and how it functions. The source
# code to MAME serves as this documentation. The fact that the software
# is usable serves primarily to validate the accuracy of the
# documentation (how else can you prove that you have recreated the
# hardware faithfully?). Over time, MAME (originally stood for Multiple
# Arcade Machine Emulator) absorbed the sister-project MESS (Multi
# Emulator Super System), so MAME now documents a wide variety of
# (mostly vintage) computers, video game consoles and calculators, in
# addition to the arcade video games that were its initial focus.
#
# Homepage: http://mamedev.org/
#
# Packaged by Cyberzinho Punk d'Noir (cyberzinho.punk@gmail.com)
Package mame-0.217-i686-1cbz.txz installed.
l'ha installato regolarmente, solo che quando provo ad avviarlo da terminale, ricevo questo errore

Codice: Seleziona tutto

root@slack:~# mame
mame: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

faccio una ricerca nel mio sistema per capire se quelle librerie le ho

Codice: Seleziona tutto

root@slack:~# locate libSDL2-2
/usr/lib64/libSDL2-2.0.so.0.8.0
/usr/lib64/libSDL2-2.0.so.0.4.0
/usr/lib64/libSDL2-2.0.so
/usr/lib64/libSDL2-2.0.so.0
/usr/lib64/libSDL2-2.0.so.0.4.1
come potete vedere le librerie ci sono, tuttavia il sistema non riesce a puntarle per far avviare il mame ed altri applicativi dipendenti da libSDL2
Come posso risolvere questo problema ?
Ultima modifica di shellx il gio 23 gen 2020, 0:35, modificato 1 volta in totale.
Il sistema dell'universo e dello spazio è come un immenso computer: speriamo non giri Windows

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2744
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da ponce »

hai installato un pacchetto a 32bit, mentre il tuo sistema e' a 64bit.

tra l'altro, sei sicuro che sia un pacchetto per la 14.2? perche' mi diceva il maintainer di mame che la versione 0.214 e' l'ultima che compila su slackware 14.2 (le altre necessitano di un compilatore piu' recente)...

Avatar utente
shellx
Linux 0.x
Linux 0.x
Messaggi: 17
Iscritto il: mer 12 ott 2016, 23:38
Slackware: 14.2 (64bit)
Kernel: 4.4.14
Desktop: Fluxbox
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da shellx »

ok allora ho rimosso quella di prima (0.217), ho scaricato la 0.214 a 64 bit ed installata

Codice: Seleziona tutto

installpkg mame-0.214-x86_64-1cbz.txz 
Verifying package mame-0.214-x86_64-1cbz.txz.
Installing package mame-0.214-x86_64-1cbz.txz:
PACKAGE DESCRIPTION:
# MAME is a multi-purpose emulation framework.
#
# MAME's purpose is to preserve decades of software history. As
# electronic technology continues to rush forward, MAME prevents this
# important "vintage" software from being lost and forgotten. This is
# achieved by documenting the hardware and how it functions. The source
# code to MAME serves as this documentation. The fact that the software
# is usable serves primarily to validate the accuracy of the
# documentation (how else can you prove that you have recreated the
# hardware faithfully?). Over time, MAME (originally stood for Multiple
# Arcade Machine Emulator) absorbed the sister-project MESS (Multi
# Emulator Super System), so MAME now documents a wide variety of
# (mostly vintage) computers, video game consoles and calculators, in
# addition to the arcade video games that were its initial focus.
#
# Homepage: http://mamedev.org/
#
# Packaged by Cyberzinho Punk d'Noir (cyberzinho.punk@gmail.com)
Package mame-0.214-x86_64-1cbz.txz installed.
quando lancio mame da terminale ottengo lo stesso problema di prima

Codice: Seleziona tutto

mame: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory
Il sistema dell'universo e dello spazio è come un immenso computer: speriamo non giri Windows

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2744
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da ponce »

shellx ha scritto:faccio una ricerca nel mio sistema per capire se quelle librerie le ho[/b]

Codice: Seleziona tutto

root@slack:~# locate libSDL2-2
/usr/lib64/libSDL2-2.0.so.0.8.0
/usr/lib64/libSDL2-2.0.so.0.4.0
/usr/lib64/libSDL2-2.0.so
/usr/lib64/libSDL2-2.0.so.0
/usr/lib64/libSDL2-2.0.so.0.4.1
sembra che tu abbia installato almeno tre versioni diverse delle librerie: io qui le ho installate da SBo e ho queste

Codice: Seleziona tutto

# ls -la /usr/lib64/libSDL2-2.0.so*
lrwxrwxrwx 1 root root      16 Dec  8 07:17 /usr/lib64/libSDL2-2.0.so -> libSDL2-2.0.so.0*
lrwxrwxrwx 1 root root      20 Dec  8 07:17 /usr/lib64/libSDL2-2.0.so.0 -> libSDL2-2.0.so.0.9.0*
-rwxr-xr-x 1 root root 1497872 Dec  8 07:17 /usr/lib64/libSDL2-2.0.so.0.9.0*
# ls -la /var/log/packages/SDL2*
-rw-r--r-- 1 root root 4850 Dec  8 07:17 /var/log/packages/SDL2-2.0.9-x86_64-1ponce
-rw-r--r-- 1 root root  943 Dec  8 07:18 /var/log/packages/SDL2_ttf-2.0.14-x86_64-1ponce
cosa dicono gli stessi comandi lanciati nella tua installazione?

inoltre non conosco il pacchettizatore da cui prendi il pacchetto e non so quindi come lo abbia compilato e su quale piattaforma (se l'hai preso dal suo spazio su sourceforge non mi sembra che lo dica): puoi farti un pacchetto da solo usando lo script che e' su SBo.

Avatar utente
shellx
Linux 0.x
Linux 0.x
Messaggi: 17
Iscritto il: mer 12 ott 2016, 23:38
Slackware: 14.2 (64bit)
Kernel: 4.4.14
Desktop: Fluxbox
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da shellx »

il pacchetto l'ho preso da qui: https://sourceforge.net/projects/mamefo ... ame/0.214/
questo è cio che mi dice la mia installazione lanciando quei comandi

Codice: Seleziona tutto

root@slack:/etc/slackpkg# ls -la /usr/lib64/libSDL2-2.0.so*
lrwxrwxrwx 1 root root      16 Nov  7 23:58 /usr/lib64/libSDL2-2.0.so -> libSDL2-2.0.so.0*
lrwxrwxrwx 1 root root      20 Nov  8 03:12 /usr/lib64/libSDL2-2.0.so.0 -> libSDL2-2.0.so.0.4.0*
-rwxr-xr-x 1 root root 1062312 Nov  8 00:38 /usr/lib64/libSDL2-2.0.so.0.4.0*
-rwxr-xr-x 1 root root 1304104 Mar  5  2017 /usr/lib64/libSDL2-2.0.so.0.4.1*
-rwxr-xr-x 1 root root 1435944 Jul 19  2018 /usr/lib64/libSDL2-2.0.so.0.8.0*

Codice: Seleziona tutto

root@slack:/etc/slackpkg# ls -la /var/log/packages/SDL2*
-rw-r--r-- 1 root root 3518 Nov  8 03:12 /var/log/packages/SDL2-2.0.4-x86_64-1_SBo
-rw-r--r-- 1 root root 3495 Nov  7 23:30 /var/log/packages/SDL2-2.0.5-x86_64-1_ejt
-rw-r--r-- 1 root root 4785 Nov  7 23:58 /var/log/packages/SDL2-2.0.8-x86_64-1_slonly
Il sistema dell'universo e dello spazio è come un immenso computer: speriamo non giri Windows

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2744
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da ponce »

ne devi installare una versione soltanto: rimuovi quelle che hai installato e compilati e installa SDL2, SDL2_ttf e mame dall'ultima versione del repository di SBo.

come considerazione a margine, personalmente non so come darti supporto per pacchetti fatti da persone che non conosco e che non testero' sulle mie installazioni perche' non ho idea di come li abbia fatti (non ci sono nemmeno i sorgenti), ci sta anche che pure il pacchetto della 0.214 che stai provando a installare sia stato fatto su current... forse dovresti provare a contattare chi ha fatto il pacchetto.

Avatar utente
shellx
Linux 0.x
Linux 0.x
Messaggi: 17
Iscritto il: mer 12 ott 2016, 23:38
Slackware: 14.2 (64bit)
Kernel: 4.4.14
Desktop: Fluxbox
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da shellx »

Salve ancora, allora sono riuscito a eliminarne ma questo non riesco ad eliminarlo in quanto non riesco a trovare il file txz per lanciare un removepkg

Codice: Seleziona tutto

root@slack:/tmp# ls -la /var/log/packages/SDL2*
-rw-r--r-- 1 root root 4785 Nov  7 23:58 /var/log/packages/SDL2-2.0.8-x86_64-1_slonly

Codice: Seleziona tutto

root@slack:/tmp# ls -la /usr/lib64/libSDL2-2.0.so*
lrwxrwxrwx 1 root root      16 Nov  7 23:58 /usr/lib64/libSDL2-2.0.so -> libSDL2-2.0.so.0
lrwxrwxrwx 1 root root      20 Nov  8 03:12 /usr/lib64/libSDL2-2.0.so.0 -> libSDL2-2.0.so.0.4.0
-rwxr-xr-x 1 root root 1435944 Jul 19  2018 /usr/lib64/libSDL2-2.0.so.0.8.0*
trovo lo 2.0.9 di slony ma no l"8".

Inoltre volevo segnalare che la mia versione di slackware 14.2 non è la current, almeno cosi non risulta. I pacchetti che devo scaricare sono SDL2 e SDL2_ttf, in piu il mame ultima versione di SBo. Per quanto riguarda i pacchetto SDL2 posso usare questo SDL2-2.0.9-x86_64-1ponce.txz ? E per SDL2_tttf questo SDL2_ttf-2.0.14-x86_64-1ponce.txz ? Inoltre il mame che mi hai consigliato posso avere dei link di riferimento per facilitarmi un po le cose ?
Se ho fatto confusione cone versioni di pacchetti (sdl2 e sdl2_ttf) visto che una è la 0.09 e la ttf è la 0.14, datemi gentilmente dei link diretti dove prendere tutiti pacchetti potenzialmente compatibili. Inoltre come segnalato prima non riesco a trovare quel pacchetto txz per rimuovere la vesione slonly 2.08

Scusate ma come ho gia detto non ci sto da molto dietro slackware.
Ne approfitto ancora per ringraziarvi.
Il sistema dell'universo e dello spazio è come un immenso computer: speriamo non giri Windows

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2744
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da ponce »

shellx ha scritto:Salve ancora, allora sono riuscito a eliminarne ma questo non riesco ad eliminarlo in quanto non riesco a trovare il file txz per lanciare un removepkg

Codice: Seleziona tutto

root@slack:/tmp# ls -la /var/log/packages/SDL2*
-rw-r--r-- 1 root root 4785 Nov  7 23:58 /var/log/packages/SDL2-2.0.8-x86_64-1_slonly

Codice: Seleziona tutto

root@slack:/tmp# ls -la /usr/lib64/libSDL2-2.0.so*
lrwxrwxrwx 1 root root      16 Nov  7 23:58 /usr/lib64/libSDL2-2.0.so -> libSDL2-2.0.so.0
lrwxrwxrwx 1 root root      20 Nov  8 03:12 /usr/lib64/libSDL2-2.0.so.0 -> libSDL2-2.0.so.0.4.0
-rwxr-xr-x 1 root root 1435944 Jul 19  2018 /usr/lib64/libSDL2-2.0.so.0.8.0*
trovo lo 2.0.9 di slony ma no l"8".
non dovrebbe essere un problema, puoi dare il comando

Codice: Seleziona tutto

removepkg SDL2
anche piu' volte finche' non ti avra' rimosso tutti i pacchetti SDL2 installati.
Inoltre volevo segnalare che la mia versione di slackware 14.2 non è la current, almeno cosi non risulta. I pacchetti che devo scaricare sono SDL2 e SDL2_ttf, in piu il mame ultima versione di SBo. Per quanto riguarda i pacchetto SDL2 posso usare questo SDL2-2.0.9-x86_64-1ponce.txz ? E per SDL2_tttf questo SDL2_ttf-2.0.14-x86_64-1ponce.txz?
in realta' sopra non ti avevo consigliato di scaricare dei pacchetti pronti ma di farteli da solo tramite gli script disponibili su SBo...
da dove hai scaricato esattamente i pacchetti che indichi sopra? puoi mettere il link esatto ad ogni pacchetto?
Inoltre il mame che mi hai consigliato posso avere dei link di riferimento per facilitarmi un po le cose ?
https://slackbuilds.org/howto/
se il pacchetto che vuoi installare ha delle dipendenze, ovviamente devi installare prima quelle.
Se ho fatto confusione cone versioni di pacchetti (sdl2 e sdl2_ttf) visto che una è la 0.09 e la ttf è la 0.14, datemi gentilmente dei link diretti dove prendere tutiti pacchetti potenzialmente compatibili. Inoltre come segnalato prima non riesco a trovare quel pacchetto txz per rimuovere la vesione slonly 2.08

Scusate ma come ho gia detto non ci sto da molto dietro slackware.
Ne approfitto ancora per ringraziarvi.

Avatar utente
shellx
Linux 0.x
Linux 0.x
Messaggi: 17
Iscritto il: mer 12 ott 2016, 23:38
Slackware: 14.2 (64bit)
Kernel: 4.4.14
Desktop: Fluxbox
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da shellx »

da dove hai scaricato esattamente i pacchetti che indichi sopra? puoi mettere il link esatto ad ogni pacchetto?
https://slackware.pkgs.org/14.2/ponce-x ... e.txz.html
https://slackware.pkgs.org/14.2/ponce-x ... e.txz.html
Il sistema dell'universo e dello spazio è come un immenso computer: speriamo non giri Windows

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2744
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da ponce »

ti sconsiglio vivamente di usare pkgs.org: e' un sito di m***a pieno di pubblicita' che indicizza i siti degli altri, senza risoluzione delle dipendenze, mescolando vari repository che hanno librerie di versioni diverse che spesso non possono essere usate contemporaneamente (di li' probabilmente l'origine dei tuoi problemi).
inoltre, cosi' facendo, si perde lo scopo originale dei repository che vengono indicizzati.
ad esempio, nella directory che contiene i pacchetti c'e' (lo so perche' ce l'ho messo io :) ) un file che chi scarica i pacchetti dovrebbe leggere (ovviamente, chi passa da pkgs.org lo ignora completamente), lo incollo qua per tua comodita'

Codice: Seleziona tutto

personal packages repository for slackware64-14.2
--------------------------------------------------

this is my personal repository for slackware64-14.2: these are
the packages I use on my own installations.
you are free to use this stuff but there are no guarantees they
will work for you (in particular if used with packages from other
third party repositories), nor I take any responsibility if your
cat is harmed during their use. :)
if not yet clear, this means this repository is *UNSUPPORTED*.

you can check for dependencies on SlackBuilds.org if you need
single packages (optional dependencies might be also required), but
all you need besides a 14.2 full default installation should
be already in this folder.
MANDATORY: install the full set, package managers are *UNSUPPORTED*
too ;)

before installing the whole, run these commands to create the
needed users/groups:

groupadd -g 210 clamav
useradd -u 210 -d /dev/null -s /bin/false -g clamav clamav
groupadd -g 220 tor
useradd -u 220 -g 220 -c "The Onion Router" -d /dev/null -s /bin/false tor
groupadd -g 206 privoxy
useradd -u 206 -g 206 -c "Web Proxy" -d /dev/null -s /bin/false privoxy
groupadd -g 208 lighttpd
useradd -u 208 -g lighttpd -d /var/www lighttpd

some packages might require additional steps: you are invited to
read their README on SlackBuilds.org.

(latest global rebuild october 9th 2019)
spero di averti chiarito.

personalmente ti rinnovo il consiglio di installare quello che ti serve da slackbuilds.org: sono tre pacchetti da fare e installare, SDL2, SDL2_ttf e mame (in quest'ordine, puoi utilizzare l'howto).

ah, giusto perche' ho notato che avevi diverse versioni degli stessi pacchetti installati e non e' proprio il caso: per evitare questo problema ti conviene installare pacchetti utilizzando il comando

Codice: Seleziona tutto

upgradepkg --install-new --reinstall nomepacchetto.txz
invece del semplice installpkg, che non aggiorna i pacchetti.

Avatar utente
shellx
Linux 0.x
Linux 0.x
Messaggi: 17
Iscritto il: mer 12 ott 2016, 23:38
Slackware: 14.2 (64bit)
Kernel: 4.4.14
Desktop: Fluxbox
Contatta:

Re: mame e libSDL2-2.0.so.0

Messaggio da shellx »

Eccomi qui, fatto tutto ciò che l'utente ponce mi ha consigliato, ossia elimianre tutte le librerie per reinstallare quelle da lui citatomi nei post precedenti, l amia situazione attuale è la seguente

Codice: Seleziona tutto

root@slack:/tmp# ls -la /var/log/packages/SDL2*
-rw-r--r-- 1 root root 4845 Jan 21 17:44 /var/log/packages/SDL2-2.0.9-x86_64-1_SBo
-rw-r--r-- 1 root root  938 Jan 21 17:48 /var/log/packages/SDL2_ttf-2.0.14-x86_64-1_SBo
root@slack:/tmp# ls -la /usr/lib64/libSDL2-2.0.so*
lrwxrwxrwx 1 root root      16 Jan 21 17:44 /usr/lib64/libSDL2-2.0.so -> libSDL2-2.0.so.0*
lrwxrwxrwx 1 root root      20 Jan 21 17:44 /usr/lib64/libSDL2-2.0.so.0 -> libSDL2-2.0.so.0.9.0*
-rwxr-xr-x 1 root root 1497872 Jan 21 17:38 /usr/lib64/libSDL2-2.0.so.0.9.0*
A questo punto scarico il mame da SBo (mame 0.214) e lo compilo, dopo 10 ore (si avete capito bene 10 ore esatte di orologio, la macchina è un semplice netbook con un atom e 2gb di ram) di compilazione il tutto termina a terminale in questo modo

Codice: Seleziona tutto

..........
install/
install/doinst.sh
install/slack-desc

Slackware package /tmp/mame-0.214-x86_64-1_SBo.tgz created.
Installo il file usando il comando "upgradepkg" e mi deleta delle vecchie directory del mame 0.215 di una vecchio mio tentativo di installazione, immagino per sostituirle al 0.214, l'installazione termina con

Codice: Seleziona tutto

........
--> Deleting empty directory /usr/doc/mame-0.215/man/
  --> Deleting empty directory /usr/doc/mame-0.215/

Verifying package mame-0.214-x86_64-1_SBo.tgz.
Installing package mame-0.214-x86_64-1_SBo.tgz:
PACKAGE DESCRIPTION:
# mame (Multiple Arcade Machine Emulator)
#
# MAME stands for Multiple Arcade Machine Emulator. When used in
# conjunction with images of the original arcade game's ROM and disk
# data, MAME attempts to reproduce that game as faithfully as possible
# on a more modern general-purpose computer. MAME can currently emulate
# several thousand different classic arcade video games from the late
# 1970s through the modern era.
#
# This package was built without the qt5 ROM debugger.
#
Executing install script for mame-0.214-x86_64-1_SBo.tgz.
Package mame-0.214-x86_64-1_SBo.tgz installed.

Package mame-0.164-x86_64-1cbz upgraded with new package ./mame-0.214-x86_64-1_SBo.tgz.
A quanto pare ci stava piu di una versione (anche una 0.164) installata (vecchi tentavivi invani fatti da me), il comando upgradepkg è stato utilissimo a riguardo a deletare delle directory di una versione 0.215 e sostiuire una versione piu vecchia rispetto la 0.214 (ringrazio ponce anch per questo consiglio).
Lancio il mame da terminale e senza nessun tipo di problema si avvia. Il problema a questo punto è risolto.

Ho imparato che le prossime volte i pacchetti li reperisco da SBo ed ad ogni pacchetto ne controllo prima i REQUIRED (come è giusto che sia), infatti sto facendo lo stesso adesso con altri applicativi dove in passato mi inceppavano le installazioni (es mednafen che poi richiede anch'esso solo SDL2, oppure bsnes che ha bisogno "retroarch" ed altri di altra natura.) E soprattutto di evitare di usare pkgs.org che fino ad oggi mi ha non solo arrecato confusione non facendomi capire le logiche di slackware (visto che provengo da debian dove nella maggiorparte dei casi tutto si installa con un "apt-get install" centralizzato a repository gia pacchettizzati e compilati - a parte installazioni da sorgenti tramite "make") ma soprattutto incasinandomi il sistema di m...da che sto provvedendo adesso a ripulire da vecchi errori a causa di quel sito.
Ringrazio ponce per il professionale e paziente supporto. ;)
Il sistema dell'universo e dello spazio è come un immenso computer: speriamo non giri Windows

Rispondi