Installazione VLC su current

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Installazione VLC su current

Messaggio da Black bart »

Salve a tutti,sto cercando di installare vlc 3.0.8 dal sito di ponce utilizzando sbopkg configurato per sbo-git.
Ho notato che ci sono un sacco di dipendenze,io al momento ho compilato ed installato QT5 che ho letto essere una dipendenza obbligatoria,la mia domanda è come vi comportate voi in un caso del genere con un sacco di pacchetti da installare e con le dipendenze delle dipendenze,cioè fate tutto a mano cercando i pacchetti uno ad uno oppure esiste un metodo diverso?

Grazie delle info...

Avatar utente
conraid
Staff
Staff
Messaggi: 13439
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Installazione VLC su current

Messaggio da conraid »

Senti, non me ne voglia ponce, ma per vlc uso il pacchetto precompilato di Alien in restricted_sbrepos :)

http://bear.alienbase.nl/mirrors/people ... d_sbrepos/

Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Re: Installazione VLC su current

Messaggio da Black bart »

Avevo scaricato anch'io quello ma non si avvia,da terminale mi da quest'errore:

Codice: Seleziona tutto

VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[00000000022dfc50] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
Errore di segmentazione

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3173
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Installazione VLC su current

Messaggio da joe »

Se lo avete preso da qui:
http://bear.alienbase.nl/mirrors/people ... 86_64/vlc/

Vedo che c'è anche un file .dep, che immagino elenchi alcuni pacchetti di dipendenza da avere sul sistema per far girare vlc di alien:
http://bear.alienbase.nl/mirrors/people ... 1alien.dep

Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Re: Installazione VLC su current

Messaggio da Black bart »

Ho provato a lanciarlo da terminale e mi da:

Codice: Seleziona tutto

VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[00000000022c27d0] dbus interface error: Failed to connect to the D-Bus session daemon: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[00000000022c27d0] main interface error: no suitable interface module
[00000000021f9c50] main libvlc error: interface "dbus,none" initialization failed
No protocol specified
[00000000022c4170] main interface error: no suitable interface module
[00000000021f9c50] main libvlc error: interface "globalhotkeys,none" initialization failed
[00000000021f9c50] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
Errore di segmentazione

Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Re: Installazione VLC su current

Messaggio da Black bart »

Ho provato vlc 2.2.8 e funziona benissimo senza problemi...

Avatar utente
conraid
Staff
Staff
Messaggi: 13439
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Installazione VLC su current

Messaggio da conraid »

Io uso il suo kde5 e non ho pronlemi, però come ti han segnalato installa le dipendenze

Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Re: Installazione VLC su current

Messaggio da Black bart »

conraid ha scritto:Io uso il suo kde5 e non ho pronlemi, però come ti han segnalato installa le dipendenze
Si ovviamente le dipendenze e tutto quello che c'è dietro l'ho installato,probabilmente allora funziona se si utilizza ktown?

erio
Linux 4.x
Linux 4.x
Messaggi: 1206
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Installazione VLC su current

Messaggio da erio »

se hai usato le qt5 di sbo-git,mi sa che sono da cambiare, usa quelle di alien che sono piu' recenti....credo.

Avatar utente
conraid
Staff
Staff
Messaggi: 13439
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Installazione VLC su current

Messaggio da conraid »

Black bart ha scritto:
mer 5 feb 2020, 18:05
conraid ha scritto:Io uso il suo kde5 e non ho pronlemi, però come ti han segnalato installa le dipendenze
Si ovviamente le dipendenze e tutto quello che c'è dietro l'ho installato,probabilmente allora funziona se si utilizza ktown?
No, perché è fuori ktown, però come dice @erio forse per la versione delle qt5

Black bart
Linux 2.x
Linux 2.x
Messaggi: 286
Iscritto il: sab 20 apr 2013, 23:10
Nome Cognome: Omar
Slackware: Slackware64-current
Desktop: xfce
Località: Bergamo

Re: Installazione VLC su current

Messaggio da Black bart »

Era proprio quello il problema,installato qt5 di alien e tutto funziona
Grazie

gian_d
Linux 2.x
Linux 2.x
Messaggi: 220
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Installazione VLC su current

Messaggio da gian_d »

Anche se vedo che è stato risolto, aggiungo i miei 10 cent. Io mi sono abituato all'idea di installare tutte le dipendenze e seguo quindi un ordine nella compilazione e installazione. In passato mi conservato tutti gli slackbuild e i sorgenti ordinati all'interno di singole directory dedicate al software principale (una per vlc, una per Blender, una per qgis, e via dicendo). Attualmente però, dato che fra una cosa o l'altra ho circa 250 pacchetti installati tra slackbuild del repository di Ponce e slackbuild miei, ho cambiato criterio per lo storage e gli aggiornamenti. Questo perché alla fine saltano fuori pacchetti che sono dipendenze incrociate per più applicazioni.
Mi sono fatto un database di tutti i pacchetti su LibreOffice base, associando a ciascun pacchetto due tabelle, le dipendenze a monte e a valle. Fatto questo, ogni pacchetto ha un numero di priorità da 0 a 10 nell'ordine di compilazione e installazione e viene conservato (slackbuild, sorgenti, patch, ecc.) con l'ultima versione compilata del pacchetto in una directory propria inclusa in una directory di classificazione (sistema, sviluppo, multimedia, grafica, python, ecc.)
In sostanza, per tracciare lo stato dei pacchetti esterni installati, uso questo:
Immagine
Apparentemente sembra una cosa farraginosa e in effetti per allestire il tutto ho dovuto spenderci un po' di tempo, ma devo dire che mi è utile, come successo di recente, se devo fare un'installazione da zero di tutti i pacchetti oppure di eseguire delle ricompilazioni a cascata in seguito ad aggiornamenti o riconfigurazione di installazioni con l'inserimento di dipendenze opzionali: seguendo l'ordine di priorità che ho impostato lancio le compilazioni di 3-4 slackbuild in contemporanea senza dovermi preoccupare di verificare le dipendenze. Peraltro non devo affidarmi alla memoria o a ricerche complicate se decido di rimuovere un pacchetto con le dipendenze non condivise. Ne ho parecchi che si incrociano perché richiesti da Qgis, vlc, ffmpeg e Blender

A parte questo, con vlc non ho mai incontrato problemi usando tutti gli slackbuild del repository di Ponce, mentre in passato ne ho incontrati usando qualche dipendenza precompilata. Attualmente non ho un solo pacchetto di quelli precompilati da Alien, Ponce, Conraid, ecc.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3173
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Installazione VLC su current

Messaggio da joe »

Se ricordo bene la presente discussione, i problemi sono diversi:

1) usare il software di SBo sulla current è comunque potenzialmente causa di guai. Siccome il repo SBo ufficiale è per la 14.2, può contenere roba vecchia, v.di caso di qt5 sopra se ho ben capito. E non è detto che nel repo di Ponce SBo-git tale software sia già stato "adattato" e testato sulla Curent. Per alcuni software non c'è problema, per altri sì, ad esempio venti giorni fa avevo tentato di installare i driver nvidia da SBo-git, il repo di Ponce li pescava da SBo-14.2 e la loro versione non era compatibile col nuovo kernel della Current. Alla fine Ponce mi ha inviato uno slackbuild ad hoc che poi ho ritoccato anch'io e lo ha poi aggiunto al repo SBo-git in forma effettivamente adattata alla Current.

2) se poi si mescolano pacchetti ufficiali per Current (che cambiano in continuo se si tiene aggiornato il sistema), pacchetti di repo terzi tipo Alien, Conraid ecc, e allo stesso tempo si pescano slackbuilds da SBo-git. Si può avere a che fare con qualche problema di versioni non compatibili tra loro (tipo vlc nuovo che vuole qt5 più recente di quello su SBo-git).

Per l'ordine delle dipendenze, parlando di SBo esiste il tool sqg.
Tempo fa avevo deciso di aggiornare, quindi compilare e ricompilare tutti i pacchetti SBo installati sul sistema.
Mi ero posto il problema dell'ordine di compilazione: se pippo dipende da pluto e aggiorno prima pippo, questo potrebbe "legarsi" al vecchio pluto, e quando poi vado ad aggiornare anche pluto, pippo non trova più quello vecchio a cui era legato. In sintesi, a volte non c'è problema ma è sempre meglio compilare i software in ordine.
Per determinare l'ordine giusto avevo fato uno script che usava sqg (e mi pare anche hoorex, ma vado a memoria) per ottenere le code di dipendenze di ciascun pacchetto SBo presente sul sistema. Da tutte queste code di dipendenza (sono già code oridinate, ovvero i pacchetti sono stampati nel giusto ordine in cui vanno compilati) avevo ottenuto una coda unica con tutti i software _SBo presenti sul sistema disposti in ordine di compilazione.
Alla fine era bastato dare la coda in pasto a sbopkg e ha ricompilato tutto il parco SBo, prendendo le nuove versioni dei software e di fatto aggiungendo anche eventuali nuove dipendenze che le vecchie versioni non richiedevano.
Ho ritrovato anche la discussione con in allegato lo script e i dettagli: https://slacky.eu/forum/viewtopic.php?f=2&t=40678
Il punto è che una roba del genere, sulla stabile funziona con una probabilità piuttosto alta (ci possono essere comunque problemi di compatibilità con pacchetti extra SBo), ma sulla Current, non è mica detto che tutto fili liscio per quanto ho spiegato ad inizio post: qualche pacchetto della coda (nella versione e con lo slackbuild SBo potrebbe non compilare su Current.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 220
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Installazione VLC su current

Messaggio da gian_d »

Sarà, ma a parte un intoppo con cuda toolkit che per ora ho lasciato in disparte, l'unico ostacolo insormontabile è che non riesco a far funzionare in runtime PyQt5 all'interno di Qgis con conseguente disabilitazione del supporto a Python all'avvio dell'applicazione. Sono mesi che mi sbatto, dopo tanti tentativi con errori in compilazione, alla fine riesco a compilare, sembra che vada tutto bene ma poi mi compare sempre lo stesso dannato avviso all'avvio di Qgis. Pazienza, ormai ci rinuncio anche perché alla fine posso usare la piattaforma per gli scopi essenziali.
Per il resto, gli slackbuild del repository di Ponce vanno bene, qualche volta c'è qualche problemino che è comunque superabile.

Rispondi