Project ERROR: Qt 5.2 or greater is required

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
gian_d
Linux 2.x
Linux 2.x
Messaggi: 226
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Project ERROR: Qt 5.2 or greater is required

Messaggio da gian_d »

Questo messaggio di errore è restituito dalla compilazione via slackbuild di decklink-sdk (dipendenza opzionale di ffmpeg) dopo l'aggiornamento di Qt5 alla versione 5.13.2, ma credo si abbia lo stesso risultato anche con versioni meno recenti a partire da Qt 5.10.0 in su

In realtà l'errore è causato da qmake se nel sorgente del software da compilare è contenuta la chiamata alla funzione lessThan(QT_VERSION, 5.x ), funzione non valida per versioni di Qt5 uguali o superiori a 5.10.0 (rif: https://bugreports.qt.io/browse/QTBUG-63325 )

Io uso la versione 10.11.1 di decklink-sdk installata con lo slackbuild del repository di Ponce e ho risolto applicando la seguente patch:

Codice: Seleziona tutto

--- "Blackmagic DeckLink SDK 10.11.1/Linux/Samples/H265TestEncoder/H265TestEncoder.pro"	2018-07-05 14:02:16.000000000 +0200
+++ "Blackmagic DeckLink SDK-fixed 10.11.1/Linux/Samples/H265TestEncoder/H265TestEncoder.pro"	2020-02-19 19:26:06.989562839 +0100
@@ -30,7 +30,7 @@
                src\
                ../../include
 
-lessThan(QT_VERSION, 5.2) {
+versionAtLeast($$QT_VERSION, 5.2){
 	error("Qt 5.2 or greater is required.")
 }
 
Lo slackbuild del repository è predisposto per l'installazione di una versione meno recente di Decklink SDK, in ogni modo il concetto non cambia. La compilazione funziona finché si usa una versione di Qt5 precedente alla 5.10.0 mentre va in errore se si installa il pacchetto attualmente rilasciato con la current. Perciò è sufficiente inserire la chiamata alla patch nel codice dello slackbuild.

Naturalmente il problema potrebbe presentarsi anche con la compilazione di software di terze parti i cui sorgenti non sono aggiornati per versioni di Qt5 uguali o superiori a 5.10.0. Ho visto che in rete ci sono segnalazioni relative a questo problema, più o meno recenti. Qualora dovesse succedere il sorgente va patchato sostituendo la funzione versionAtLeast() al posto di lessThan()

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2751
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: Project ERROR: Qt 5.2 or greater is required

Messaggio da ponce »

ma hai una scheda di acquisizione blackmagic?

comunque ti conviene segnalarlo direttamente al maintainer di decklink-sdk, perche' molto presto sara' aggiornato qt5 anche per la 14.2 (alla 5.12.x, probabilmente).

gian_d
Linux 2.x
Linux 2.x
Messaggi: 226
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Project ERROR: Qt 5.2 or greater is required

Messaggio da gian_d »

No :-D
Diversi pacchetti soprattutto della categoria del multimediale sono installati finché non mi prendo la briga di leggere a che servono, allora nel dubbio li installo con l'intento di documentarmi prima o poi. Cosa che faccio molto raramente per pigrizia o per tempo e soprattutto perché in fatto di multimediale sono un emerito ignorante dato che poi mi limito poi a ritoccare file video con avidemux e file audio con audacity.
Però proprio a causa della mia ignoranza installo anche tutte le dipendenze opzionali per pacchetti come vlc o librerie base come ffmpeg contando sul fatto che potrebbero aggiungere funzionalità o meno a questo software.

Dalla tua obiezione ora capisco che non mi serve a un piffero. E con questo mi spiego perché il sito di Blackmagick vende hardware. Va be', fatti due risate ma abbi pietà e non infierire su un povero vecchio utonto :-D

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2751
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: Project ERROR: Qt 5.2 or greater is required

Messaggio da ponce »

comunque non era un'obiezione: lo chiedevo perche' io per esempio ne ho una e l'ho usata per acquisire vecchie videocassette (anche se ha una grossa varieta' di ingressi anche per altro). :)

gian_d
Linux 2.x
Linux 2.x
Messaggi: 226
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Project ERROR: Qt 5.2 or greater is required

Messaggio da gian_d »

Una dozina di anni fa mi sarebbe interessato perché era in progetto, ho ancora un serie di videocassette conservate, ma nel frattempo non ho più il lettore di videocassette e penso che queste siano ormai rovinate dal tempo. Peraltro se dovessi installare una scheda di acquisizione dovrei pagare il canone RAI, che invece non pago perché non ho nessun apparecchio TV e nessun dispositivo abilitato a ricevere/acquisire segnali TV.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2751
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: Project ERROR: Qt 5.2 or greater is required

Messaggio da ponce »

il modello di scheda che ho io non ha un sintonizzatore integrato. ;)

Rispondi