[risolto] emulatori terminale non funzionanti dopo aggiornamento current con slackpkg

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
red
Linux 3.x
Linux 3.x
Messaggi: 794
Iscritto il: gio 20 gen 2005, 0:00
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox
Località: Verona
Contatta:

[risolto] emulatori terminale non funzionanti dopo aggiornamento current con slackpkg

Messaggio da red »

Ciao a tutti,
normalmente tengo aggiornata la mia Current64 con slackpkg con in blacklist i pacchetti del kernel.

Solita procedura:
update
upgrade slackpkg
install-new
upgrade-all
clean-system

Mi sono recentemente accorto che a parte konsole e xterm, gli altri emulatori non funzionano, in particolare rxvt e aterm.
Avete idea di quale possa essere il problema?

Grazie!

[edit] Dimenticavo: in /usr/bin non ci sono gli eseguibili, anche dopo aver ricompilato ed installato il relativo slackbuild
Ultima modifica di red il mer 22 lug 2020, 14:35, modificato 1 volta in totale.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2763
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: emulatori terminale non funzionanti dopo aggiornamento current con slackpkg

Messaggio da ponce »

ciao red,

puoi provare a vedere quello che succede se provi a lanciarli da un'altro emulatore di terminale: prova ad aprire un xterm e poi lancia il comando

Codice: Seleziona tutto

urxvt
(questo e' il nome del binario di rxvt-unicode, incluso in Slackware current) che output ti restituisce?

aterm non e' compreso proprio in current e per installarlo devi prendere lo script su SBo e aggiungere questa riga allo SlackBuild, prima della linea che inizia con "CFLAGS"

Codice: Seleziona tutto

sed -i 's%<sys/stropts.h>%<sys/ioctl.h>%;s%I_PUSH,%TIOCPKT,%' src/command.c

Avatar utente
red
Linux 3.x
Linux 3.x
Messaggi: 794
Iscritto il: gio 20 gen 2005, 0:00
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox
Località: Verona
Contatta:

Re: emulatori terminale non funzionanti dopo aggiornamento current con slackpkg

Messaggio da red »

In effetti aterm è andato a posto con quella modifica.
rxvt invece non funzionava in alcun modo.
Ho iniziato a pensare fosse andato storto qualcosa nell'aggiornamento dei pacchetti.
Ho finito giusto ora di reinstallare gli ultimi aggiornamenti e stavo proprio per scrivere che adesso rxvt funziona.
Con la tua dritta sullo slackbuilds ora è a posto anche aterm, quindi risolto!

Grazie per le info :D

Rispondi