Layout di tastiera taroccato dopo aggiornamento di libxkbcommon [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
gian_d
Linux 2.x
Linux 2.x
Messaggi: 261
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Layout di tastiera taroccato dopo aggiornamento di libxkbcommon [RISOLTO]

Messaggio da gian_d »

Non so per quale motivo, ma poco fa ho aggiornato libxkbcommon su current all`ultima versione, rilasciata ieri, e ora non riesco piu` a utilizzare la tastiera italiana in ambiente grafico. Il login da kdm mi carica la tastiera US nonostante su kde sia impostata la mappatura italiana.
Sicuramente con l`aggiornamento deve essere cambiato qualcosa che richiede una configurazione specifica, a meno che non ci sia un bug, cosa di cui dubito, ma non so quali impostazioni debba fare nei file di configurazione di xorg, di solito non opero impostazioni personalizzate nel layout di tastiera perche` le faccio da KDE. In passato modificavo il file /etc/xorg.conf ma non lo faccio piu` da anni perche` il server grafico si autoconfigura in genere con l`installazione del driver di nvidia senza dover preimpostare configurazioni specifiche, percio` non ho mai messo mano nelle directory xkb e xorg.conf.d
Non sapendo dove mettere le mani e vorrei evitare di combinare pasticci, per ora faccio un downgrade della libreria, ma prima o poi dovro` affrontare il problema, percio` ringrazio chiunque possa darmi qualche dritta

Non so se sia importante, comunque ho una scheda grafica Pny e uso il driver proprietario di Nvidia
Ultima modifica di gian_d il mer 9 set 2020, 22:33, modificato 1 volta in totale.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 261
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Layout di tastiera taroccato dopo aggiornamento di libxkbcommon

Messaggio da gian_d »

Ahi, non so che cavolo possa essere successo, ma anche facendo il downgrade della libreria continua ad essere impostata la tastiera americana. Fino a qualche ora fa funzionava tutto regolarmente, le sole variazioni che ci sono state consistono nell`aggiornamento dei pacchetti della current rilasciati il 7 e l`8 settembre e l`unica modifica che possa aver interferito con il server grafico riguarda proprio l`aggiornamento di libxkbcommon.
Il problema e` comunque nel server grafico, perche` aprendo un terminale fuori dal server grafico la mappatura della tastiera e` quella italiana

il comando setxkbmap mi restituisce questo output

Codice: Seleziona tutto

$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /etc/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     us
options:    terminate:ctrl_alt_bksp
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us+inet(evdev)+terminate(ctrl_alt_bksp)
geometry:   pc(pc105)
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us+inet(evdev)+terminate(ctrl_alt_bksp)"    };
        xkb_geometry  { include "pc(pc105)"     };
};

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2758
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: Layout di tastiera taroccato dopo aggiornamento di libxkbcommon

Messaggio da ponce »


gian_d
Linux 2.x
Linux 2.x
Messaggi: 261
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Layout di tastiera taroccato dopo aggiornamento di libxkbcommon

Messaggio da gian_d »

grazie Matteo, ora mi studio la cosa!

gian_d
Linux 2.x
Linux 2.x
Messaggi: 261
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Layout di tastiera taroccato dopo aggiornamento di libxkbcommon [RISOLTO]

Messaggio da gian_d »

ok, risolto copiando uno dei file di configurazione della tastiera da /usr/share/X11/ in /etc/X11/xorg.conf.d e impostando a "it" l'opzione locale

Adesso proverò a capire cosa diavolo possa essere successo con l'aggiornamento di libxkbcommon: xorg.conf.d l'ho sempre lasciato vuoto, sicuramente c'è stata qualche variazione che non fa più funzionare la configurazione se impostata all'interno di KDE. Infatti ho provato a impostare la tastiera americana da KDE ma non succede nulla, continua a funzionare la tastiera italiana.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 261
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: Layout di tastiera taroccato dopo aggiornamento di libxkbcommon [RISOLTO]

Messaggio da gian_d »

Scoperto l'arcano, naturalmente era tutta colpa dei miei neuroni. Non dipendeva da libxkbcomm ma da kded. Negli ultimi due aggiornamenti c'erano anche le librerie gst-plugins e gstreamer. Quando ho scaricato i pacchetti, per distrazione non ho scaricato gstreamer, che era rimasto perciò alla vecchia versione rispetto ai tre gst-plugins.
Il risultato è che all'avvio di KDE il collegamento a libgstaudio restituiva una lista ben nutrita di errori impedendo l'avvio di una decina di servizi di KDE!
Me ne sono reso conto solo dopo vedendo che parecchie funzionalità di KDE (gestione energetica, cattura dello schermo, memorizzazione delle sessioni, ecc.) non andavano perché i servizi non erano in esecuzione e con le impostazioni del sistema non era possibile avviarli!

Per esempio:

Codice: Seleziona tutto

kded(3528) Kded::loadModule: Could not load library "kded_powerdevil" . [ "Impossibile caricare la libreria /usr/lib64/kde4/kded_powerdevil.so: (/usr/lib64/libgstaudio-1.0.so.0: undefined symbol: gst_aggregator_selected_samples)" ]
This backend is only for XRandR 1.1, your version is:  1 . 6 
kded(3528) Kded::loadModule: Could not load library "kded_keyboard" . [ "Impossibile caricare la libreria /usr/lib64/kde4/kded_keyboard.so: (/usr/lib64/libgstaudio-1.0.so.0: undefined symbol: gst_aggregator_selected_samples)" ] 
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.5'
Could not open library ksmserver: Cannot load library /usr/lib64/libkdeinit4_ksmserver.so: (/usr/lib64/libgstaudio-1.0.so.0: undefined symbol: gst_aggregator_selected_samples)
Naturalmente dopo l'aggiornamento anche di gstreamer ora funziona tutto regolarmente.

L'eccesso di confidenza a volte ti porta a commettere errori di una stupidità indicibile :-\

Rispondi