current, python 3.9 e kde5

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
conraid
Staff
Staff
Messaggi: 13508
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

current, python 3.9 e kde5

Messaggio da conraid »

Ahia, leggo da Alien
I suggest that you wait with upgrading to the latest -current for a short while. Give Pat a chance to add Plasma5 to Slackware, because I am not going to recompile any ‘ktown’ package over this.
I will however look at my other packages (cecilia5, wxpython to name but a few) and recompile those against the newer Python. Watch this space for more news.
speriamo Pat faccia presto allora. Che altrimenti ci tocca aspettare ad aggiornare la current. Chi utilizza ktown di Alien naturalmente.

roberto67
Packager
Packager
Messaggi: 330
Iscritto il: lun 14 set 2009, 18:55
Slackware: current multilib
Desktop: plasma 5
Contatta:

Re: current, python 3.9 e kde5

Messaggio da roberto67 »

we needed to get this out of the way before moving on to bigger and better things. :-)
Ad essere ottimisti si potrebbe interpretare questo nel changelog come un segno che plasma5 sia alla prossima grossa fermata... speriamo

OT forse c'è da aggiornare l'ora del server di slacky...

Avatar utente
conraid
Staff
Staff
Messaggi: 13508
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: current, python 3.9 e kde5

Messaggio da conraid »

Sì, anche da quel che dice Alien, speriamo.

P.S.
A me indica l'ora giusta.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 284
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: current, python 3.9 e kde5

Messaggio da gian_d »

premesso che uso ancora kde 4, spero che sia l'unico problema, ho parecchi pacchetti da slackbuild basati su Python!

Avatar utente
conraid
Staff
Staff
Messaggi: 13508
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: current, python 3.9 e kde5

Messaggio da conraid »

Devi ricompilarli tutti ahimè. Io son già all'opera :)

Questa è la lista di quelli che ho io

Codice: Seleziona tutto

alabaster
asn1crypto
beautifulsoup4
cachetools
cffi
chump
click
collectd
colorama
decorator
defusedxml
docker-compose
docker-pycreds
enum
eyed3
fontforge
futures
gdata-python-client
gitdb
gitpython
glade
goobook
google-api-core
google-api-python-client
google-auth
google-auth-httplib2
googleapis-common-protos
greenlet
html5lib-python
httpie
imagesize
jinja2
libopenshot
libvirt
lxml
mps-youtube
msgpack-python
mutagen
neovim
nvchecker
nyx
oauth2client
paramiko
psutil
psycopg2
pyasn1
pyasn1-modules
pycparser
pycrypto
pyinotify
pylibacl
pynacl
pynvim
pypdf2
pypoppler
pypubsub
pyquery
pyrit
pyte
python-attrs
python-babel
python-bcrypt
python-cached-property
python-cheetah3
python-cssselect
python-dateutil
python-docker
python-dockerpty
python-docopt
python-evdev
python-fuse
python-h11
python-h2
python-hpack
python-hstspreload
python-httpx
python-hyperframe
python-importlib-metadata
python-jsonschema
python-keyring
python-logzero
python-lyricwikia
python-magic
python-markupsafe
python-oauthlib
python-pafy
python-pathlib
python-pathlib2
python-polib
python-pycodestyle
python-pyrsistent
python-pyzmq
python-rapidfuzz
python-redis
python-regex
python-requests-oauthlib
python-rfc3986
python-rfc6555
python-selectors2
python-slip
python-sniffio
python-spotipy
python-structlog
python-texttable
python-titlecase
python-toml
python-tornado
python-trollius
python-typing-extensions
python-ujson
python-unidecode
python-uritemplate
python-urwid
python-vimgolf
python-webencodings
python-websocket-client
python-wheel
python2-pyxattr
python2-ujson
pythondialog
pytube3
pytz
pyudev
pyuv
pyxattr
pyyaml
reportlab
reppy
rsa
secretstorage
setuptools-scm
simplejson
smmap2
snowballstemmer
soupsieve
sphinx
sshtunnel
stem
thefuck
trash-cli
tweepy
twitter
udiskie
unicode-slugify
urlgrabber
urlwatch
vimtips
weechat
yara-python
youtube-dl
più cryptography markdown python-tqdm python-zipp che ho aggiornato poco fa. Ho fatto il check su python senza controllare se fosse 3 o 2, ma 2 mi sembra sono al massimo un paio.

Avatar utente
conraid
Staff
Staff
Messaggi: 13508
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: current, python 3.9 e kde5

Messaggio da conraid »

Ma se lasciassi anche il pacchetto python 3.8 installato (o magari ricreandone uno senza gli eseguibilli in bin, solo librerie) potrebbe funzionare? Non ho modo di fare test purtroppo.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 284
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: current, python 3.9 e kde5

Messaggio da gian_d »

All'interno dell'ambiente python è inevitabile che saltino fuori errori perché la versione installata di python diventa una variabile di sistema. Per il software "normale" ci saranno comportamenti differenti, secondo me dovuti al fatto che si appoggia a librerie che possono essere più o meno strettamente dipendenti da python. Ho notato che molti applicativi che hanno dipendenze python non hanno risentito, probabilmente perché queste dipendenze sono necessarie in fase di compilazione oppure per determinate funzionalità secondarie in runtime. Ma Qgis è invece andato in palla.

Alla fine mi sono armato di pazienza e ho ricompilato tutti i pacchetti python e alcuni software che avevano i binding in python3.8 (es. opencv e opencolorio. L'unico che mi è rimasto da ricompilare è qgis, che ora però non si apre perché devo aggiornare le librerie basate su boost, che è passato alla 1.74). Per i pacchetti python ci ho impiegato tutto un pomeriggio, finito solo in tarda serata. Ma a conti fatti ne valeva la pena.

A mio parere se state usando kde5 è forse opportuno non aggiornare python in attesa di sviluppi. Io ho ancora kde4 e non mi metto il problema.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 284
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.4.xx
Desktop: KDE 4.14.38
Località: Sardinia
Contatta:

Re: current, python 3.9 e kde5

Messaggio da gian_d »

Bugia, mi era sfuggito anche Blender, non si apre perché cerca qualcosa in Python3.8, ma l'ultima compilazione è stata fatta ad agosto

Avatar utente
conraid
Staff
Staff
Messaggi: 13508
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: current, python 3.9 e kde5

Messaggio da conraid »

Sì, anche perché oggi c'è anche poppler e altre librerie che Alien ricompila. Quindi dovrei ricompilarmi anche queste e magari tutti i pacchetti di ktown che dipendono da queste e da python3.9. Diventa un lavorone. Speriamo Pat faccia presto.

Rispondi