libvirt v7.1.0 con qemu 5.2.0 ed errore su chiamata liburing

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 282
Iscritto il: dom 11 gen 2004, 0:00
Slackware: current 64 bit
Kernel: 5.10.x
Desktop: KDE PLASMA
Località: Cosenza
Contatta:

libvirt v7.1.0 con qemu 5.2.0 ed errore su chiamata liburing

Messaggio da F4B1CK »

Ciao,
ho una current64 con i seguenti pacchetti, di cui alcuni appena aggiornati :

Codice: Seleziona tutto

virt-manager-3.2.0-x86_64-1cf
libvirt-7.1.0-x86_64-1cf
libvirt-glib-4.0.0-x86_64-1cf
libvirt-python-7.1.0-x86_64-1cf
virt-viewer-9.0-x86_64-2cf
qemu-5.2.0-x86_64-2cf
liburing-2.0-x86_64-1cf
purtroppo torna a non funzionare qemu, sputando questo messaggio d'errore :

Codice: Seleziona tutto

$> /usr/bin/qemu-system-x86_64
/usr/bin/qemu-system-x86_64: /usr/lib64/liburing.so.1: version `LIBURING_0.2' not found (required by /usr/bin/qemu-system-x86_64)
/usr/bin/qemu-system-x86_64: /usr/lib64/liburing.so.1: version `LIBURING_0.1' not found (required by /usr/bin/qemu-system-x86_64)
Avendo la versione 2.0 del pacchetto, questa libreria di fatto non esiste (liburing.so.1), ho semplicemente creato a mano un link simbolico, sperando funzionasse.

Qualcuno ha altre informazioni in merito, utilizzando come me i pacchetti forniti da Conraid?

Avatar utente
conraid
Staff
Staff
Messaggi: 13551
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: libvirt v7.1.0 con qemu 5.2.0 ed errore su chiamata liburing

Messaggio da conraid »

Se aspetti qualche ora metto qemu aggiornato. Mi è sfuggita la dipendenza, lo script automatico di controllo dipendenze con ssbdep non ha funzionato, eppure lanciandolo a mano me lo segnala.

Avatar utente
conraid
Staff
Staff
Messaggi: 13551
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: libvirt v7.1.0 con qemu 5.2.0 ed errore su chiamata liburing

Messaggio da conraid »


F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 282
Iscritto il: dom 11 gen 2004, 0:00
Slackware: current 64 bit
Kernel: 5.10.x
Desktop: KDE PLASMA
Località: Cosenza
Contatta:

Re: libvirt v7.1.0 con qemu 5.2.0 ed errore su chiamata liburing

Messaggio da F4B1CK »

Grazie mille!

Avevo dimenticato di rispondere sul forum.

Rispondi