Problema installazione aMule da Slackbuild

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Pigi
Linux 0.x
Linux 0.x
Messaggi: 2
Iscritto il: gio 26 apr 2018, 10:48

Re: Problema installazione aMule da Slackbuild

Messaggio da Pigi »

Ciao a tutti, e scusate l' intervento " a gamba tesa".
Il problema segnalato nel primo post riguarda un cambio di primitive della crypto++ dalla 6 in poi.

https://github.com/amule-project/amule/issues/119
ed il fix e' riportato qui:
https://github.com/amule-project/amule/ ... e7b6a3a8aa

Io pero, passato questo punto, ho un problema ( identico sia con la crypto++ >6 che con <6 ) in fase di link, ma ci sto ancora combattendo.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2859
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.14.14
Desktop: lxde
Località: Pisa
Contatta:

Re: Problema installazione aMule da Slackbuild

Messaggio da ponce »

Pigi ha scritto:Ciao a tutti, e scusate l' intervento " a gamba tesa".
Il problema segnalato nel primo post riguarda un cambio di primitive della crypto++ dalla 6 in poi.

https://github.com/amule-project/amule/issues/119
ed il fix e' riportato qui:
https://github.com/amule-project/amule/ ... e7b6a3a8aa
e' molto strano, perche' l'autore del topic diceva di aver installato cryptopp-5.6.x. da SlackBuilds.org (gliel'avevo chiesto espressamente nella prima risposta).

Pigi
Linux 0.x
Linux 0.x
Messaggi: 2
Iscritto il: gio 26 apr 2018, 10:48

Re: Problema installazione aMule da Slackbuild

Messaggio da Pigi »

Hai ragione, Ponce, ma nelle mie innumerevoli prove di compilazione ho avuto quel problema solo con la crypto++ 6.0, mentre con la 5.6.x ho ( avevo ) solo il problema di linking.
Questo problema e' poi scomparso installando la crypto++ 5.6.5 presa dal tuo repository ( a proposito, grazie :) )

Pigi

Meskalamdug
Iper Master
Iper Master
Messaggi: 3936
Iscritto il: ven 14 mag 2004, 0:00

Re: Problema installazione aMule da Slackbuild

Messaggio da Meskalamdug »

È possibile compilare amule 2.3.2 con la nuova crypto++ usando questa patch

https://gitweb.gentoo.org/repo/gentoo.g ... 0ced8f40d4

ilmich
Master
Master
Messaggi: 1591
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.2 64bit
Kernel: 4.19.46
Desktop: dwm
Località: Roma

Re: Problema installazione aMule da Slackbuild

Messaggio da ilmich »

Buongiorno a tutti,

volevo segnalare che con l'attuale RC di slackware e gli slackbuilds per current (repository git) aMule non compila piu' e ricevo questo errore

Codice: Seleziona tutto

Compiling MD5Sum.cpp
Compiling MuleDebug.cpp
MuleDebug.cpp: In function ‘void OnUnhandledException()’:
MuleDebug.cpp:70:14: error: ‘set_terminate’ is not a member of ‘std’
   70 |         std::set_terminate(std::abort);
      |              ^~~~~~~~~~~~~
MuleDebug.cpp: In function ‘void InstallMuleExceptionHandler()’:
MuleDebug.cpp:113:14: error: ‘set_terminate’ is not a member of ‘std’
  113 |         std::set_terminate(OnUnhandledException);
      |              ^~~~~~~~~~~~~
make[4]: *** [Makefile:464: MuleDebug.o] Errore 1
make[3]: *** [Makefile:427: all-recursive] Errore 1
make[2]: *** [Makefile:3345: all-recursive] Errore 1
make[1]: *** [Makefile:578: all-recursive] Errore 1
make: *** [Makefile:485: all] Errore 2
la fix è abbastanza banale e consiste nell'aggiungere

Codice: Seleziona tutto

#include <exception>
nel file libs/common/MuleDebug.cpp.
Ma in questo momento storico come si segnalano ste cose?!?! mailing list slackbuilds.org!?

grazie
Michele
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2859
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.14.14
Desktop: lxde
Località: Pisa
Contatta:

Re: Problema installazione aMule da Slackbuild

Messaggio da ponce »

in realta' questo succede perche' stai sempre usando la vecchia dipendenza wxPython, mentre compila tranquillamente se usi, al posto di wxPython, wxGTK3: la cambio subito.

ora che le submission sono chiuse e il branch master del git di SBo viene aggiornato per current puoi segnalarle o nella mailing list o direttamente a me nel topic dedicato su linuxquestions.

ilmich
Master
Master
Messaggi: 1591
Iscritto il: lun 16 lug 2007, 17:39
Slackware: 14.2 64bit
Kernel: 4.19.46
Desktop: dwm
Località: Roma

Re: Problema installazione aMule da Slackbuild

Messaggio da ilmich »

ponce ha scritto:
lun 13 set 2021, 19:13
in realta' questo succede perche' stai sempre usando la vecchia dipendenza wxPython, mentre compila tranquillamente se usi, al posto di wxPython, wxGTK3: la cambio subito.
grazie mille per il tuo incommensurabile supporto ;)
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

Rispondi