Update su vecchio SL

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
sagredo
Linux 0.x
Linux 0.x
Messaggi: 12
Iscritto il: ven 20 ago 2021, 8:38
Kernel: 2.6.32
Distribuzione: Scientific Linux 6.2
Località: Pisa

Update su vecchio SL

Messaggio da sagredo »

Saluti a tutti. En attendant slack 15.0, continuo a usare il mio vecchio SL 6.2, che ogni tanto mi pone qualche problema.
Spero che qualcuno qui possa darmi una mano.
Sto tentando d'installare una versione recente di firefox: firefox-91.4.1esr.
Con yum non lo trova, per cui ho ho scaricato il tar.
Il problema è che richiede librerie aggiornate: glibc-2.17 (la versione installata è 2.12).
Ho scaricato gli rpm, ma rifiutano l'installazione perché 2.12 è richiesta da altra applicazione e non può essere cancellata.
Preciso che gli rpm sono per el6:
glibc-2.17-55.el6.x86_64.rpm ecc.

A me sembra di ricordare che esistano scappatoie, ma non so più quali siano.
E' su questo che chiedo aiuto.
In attesa speranzosa ;)
Elio

sagredo
Linux 0.x
Linux 0.x
Messaggi: 12
Iscritto il: ven 20 ago 2021, 8:38
Kernel: 2.6.32
Distribuzione: Scientific Linux 6.2
Località: Pisa

Re: Update su vecchio SL

Messaggio da sagredo »

Non c'è nessuno?
Elio

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3414
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Update su vecchio SL

Messaggio da joe »

Scientific linux 6.2...
https://scientificlinux.org/downloads/sl-versions/sl6/

Ora, noi qui con slackware ci si lagna di dover ancora viaggiare con una release "stable" uscita un lustro fa, nel 2016.
Ma caro sagredo, perché mai FF attuale dovrebbe girare senza problemi sul tuo sistema SL-6.2 rilasciato nel 2012?

Anche SL è progredita dalla versione che hai tu:
http://ftp1.scientificlinux.org/linux/s ... 86_64/iso/

Metti la 7.9 se vuoi rimanere con SL.
Oppure prova a chiedere se qualcuno nella community di SL si trova nella tua situazione...
sinceramente dubito.

Metti Slackware-15.0_RC2 piuttosto.
Perché mantenere un sistema così obsoleto?
Se ti interessa metterci un browser è perché lo usi per finalità desktop... In tal caso una distribuzione del 2012, nel 2021 semplicemente non è pensabile.

sagredo
Linux 0.x
Linux 0.x
Messaggi: 12
Iscritto il: ven 20 ago 2021, 8:38
Kernel: 2.6.32
Distribuzione: Scientific Linux 6.2
Località: Pisa

Re: Update su vecchio SL

Messaggio da sagredo »

Grazie per la risposta, ma io avevo fatto una domanda specifica e a quella non hai risposto.
Se voglio mantenere per ora SL 6.2 avrò le mie buone ragioni, e non sono il solo.
Ne ho visti altri sulla mailing listi di SL, ma in genere sono utenti professionali, con esigenze molto diverse dalle mie.
Credi che non sappia che esiste SL 7.9? Ho la .iso su una chiavetta, ma non mi va di fare il lavoro d'installazione, migrazione di tutti i dati ecc. e poi a breve dover comunque passare a un'altra distribuzione perché SL non è più mantenuto.

Comunque ho trovato firefox-78.5.0-1.el6_10.x86_64 che si è installato senza batter ciglio e per ora risolve i problemi che avevo.
So bene che così la questione è solo rimandata. Da agosto, quando posi per la prima volta qui il problema, sto ancora aspettando la versione stabile di Slackware 15.0
Elio

rik70
Iper Master
Iper Master
Messaggi: 2292
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 5.4.x
Desktop: Xfce 4.14
Distribuzione: Arch Linux

Re: Update su vecchio SL

Messaggio da rik70 »

Puoi provare ad installare le glibc in un altro percorso e utilizzare la variabile LD_LIBRARY_PATH quando lanci firefox; oppure, se conosci l'esatta libreria richiesta, puoi provare con la variabile LD_PRELOAD.

L'ideale sarebbe compilare le giblc dai sorgenti.
Ma se hai l'rpm, scompattalo e metti il contenuto da qualche parte - esempio: /opt/glibc.

Occhio che all'occorrenza potresti dover impostare anche la variabile PATH.

Non è detto però che funzioni: dalle glibc "dipende" un botto di roba.

Buon divertimento 8)

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3414
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Update su vecchio SL

Messaggio da joe »

Un'altra via, sempre comunque tampone potrebbe essere quella di provare con gestori di pacchetti tipo:

https://flathub.org/apps/details/org.mozilla.firefox
https://snapcraft.io/firefox
https://appimage.org/

Ad esempio io su slackware-14.2 faccio girare Gimp e Scribus ultime versioni. Compilarli su questo sistema non riesce, almeno dai miei tentativi... e non riesce perché il "core" di slackware è troppo vecchio per supportare le versioni di librerie e pezzi del sistema richieste dai "nuovi software" di cui sopra (nuove versioni degli stessi, s'intende).
Con scribus ero riuscito a compilare appoggiandomi a versioni alternative di alcune librerie messe in /opt, come suggeriva rik... Ma è un bagno d sangue.

Alla fine avevo provato flatpak e nonostante non sia una roba leggerina, comunque ti ritrovi scribus ultima versione di sviluppo su un sistema nato un lustro fa. Anche per Gimp stesso discorso, la compilazione sulla vecchia slack non funziona e l'unica è stata passare da flatpak.
Gli altri due progetti non li ho provati, qualcuno me li aveva segnalati in particolare uno dei due sarebbe preferibile rispetto a flatpak per via della maggiore leggerezza dei programmi costruiti.
In effetti se lancio Gimp o Scribus da flatpak prima che si apra il programma passano 10 secondi. Però alla fine, basta ricordarsi di non chiuderli e lasciarli aperti sul loro "desktop virtuale". Insomma basta organizzarsi e come pezza per sopperire all'assenza di una release slackware abbastanza recente, diciamo che ci può stare.

Il problema per SL-6.2 è che potrebbe non essere disponibile un pacchetto per uno di questi tre software. Flatpak ho visto che c'è per la versione SL-7.x. Sicuramente sagredo da utente SL saprà cercare meglio di quanto abbia fatto io così al volo.

Rispondi