rsync in script e mount

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
conraid
Staff
Staff
Messaggi: 13580
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

rsync in script e mount

Messaggio da conraid »

ho un problema con gli script di aggiornamento dei repository

Per esempio ho questo script

Codice: Seleziona tutto

#!/bin/sh

REPO="rsync://bear.alienbase.nl/mirrors/people/alien/"
DEST="/mnt/hd/mirror/repository/alien"
EXCLUDE="--exclude-from=alien-exclude.txt"
INCLUDE="--include-from=alien-include.txt"
rsync -avP --delete-after $INCLUDE $EXCLUDE $REPO $DEST $1

REPO="rsync://bear.alienbase.nl/mirrors/alien-kde/"
DEST="/mnt/hd/mirror/repository/alien-kde"
EXCLUDE="--exclude=/14.2 --exclude=x86 --exclude=5_old"
INCLUDE="--include-from=alien-kde-include.txt"
rsync -avP --delete-after $INCLUDE $EXCLUDE $REPO $DEST $1

REPO="rsync://slackbuilds.org/slackbuilds"
DEST="/mnt/hd/mirror/repository/slackbuilds"
EXCLUDE="--exclude-from=sbo.txt"
INCLUDE=""
rsync -avP --delete-after $INCLUDE $EXCLUDE $REPO $DEST $1
Se lancio lo script mi smonta l'ha esterno usb (/mnt/hd) e da errore di i/o naturalmente.
Se lancio a mano rsync (con lo stesso identico comando che ho sopra) va tutto ok

Mi fa la stessa cosa con lo script per tenere aggiornata la slackware, in quel caso leggermente complesso che ha dei parametri, ma il risultato è lo stesso.
Da script smonta l'hs, da linea di comando (ho fatto un echo nello script quindi copio lo stesso comando) va tutto ok.

Cosa può essere?

Rispondi