NVME usb non riconosciuto

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
susumella
Linux 2.x
Linux 2.x
Messaggi: 442
Iscritto il: mar 25 mag 2004, 0:00

Re: NVME usb non riconosciuto

Messaggio da susumella »

Dunque... mettendo il disco nel laptop aziendale, parte QUASI regolarmente, nel nenso che comunque c'è qualcosa che non va in grub (mi fa partire di default il bootloader di windows, quindi devo agire a mano sul bios per selezionare grub).
Mi ricordereste gentilmente una cosa? Il disco nvme è diviso (correttamente) in 3 partizioni: nvme0n1p1, nvme0n1p2, nvme0n1p5. In più, in dev, sono presenti nvme0 e nvme0n1. In quale di queste ultime 2 va installato grub? Io l'ho installato in nvme0, ma ho il dubbio che non sia corretto. Poi... "n1" che cosa significa? Nella nomenclatura dei dischi SATA avevamo SDXpY, dove X ed Y rappresentavano rispettivamente disco e partizioni. Nel nvme abbiamo quel "n1" in più: che vuol dire?
Grazie!

rik70
Iper Master
Iper Master
Messaggi: 2365
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 4.19
Desktop: Sway
Distribuzione: Arch Linux

Re: NVME usb non riconosciuto

Messaggio da rik70 »

susumella ha scritto:
sab 16 apr 2022, 9:48
nvme0n1
Dovrebbe essere quello.
Per non sbagliare, dovrebbe bastarti l'output di

Codice: Seleziona tutto

fdisk -l
susumella ha scritto:
sab 16 apr 2022, 9:48
su quel grub ci sono diverse entry, non solo Slackware, ed il gioco non vale la candela
Per queste cose esiste il backup.
Fatti una copia di tutto quello che andrai a modificare, che poi userai per ripristinare quando rimonterai il disco sul portatile.

Perché se vuoi far partire quel disco usb le modifiche dovrai farle per forza.

susumella
Linux 2.x
Linux 2.x
Messaggi: 442
Iscritto il: mar 25 mag 2004, 0:00

Re: NVME usb non riconosciuto

Messaggio da susumella »

Dunque, la faccenda è un "attimino" più complessa... ho generato il nuovo initrd, ma il problema non è lì, quanto piuttosto che, avviando da usb, i moduli nell'initrd non vengono caricati correttamente. Alcuni falliscono (tipo jdb2 ed ext4), mentre se il pc parte con il disco montato all'interno tutto va che è una meraviglia.
Ho anche reinstallato grub, ma non cambia nulla.
Per adesso va bene così...
Grazie mille a tutti!

rik70
Iper Master
Iper Master
Messaggi: 2365
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 4.19
Desktop: Sway
Distribuzione: Arch Linux

Re: NVME usb non riconosciuto

Messaggio da rik70 »

susumella ha scritto:
sab 16 apr 2022, 11:50
ho generato il nuovo initrd, ma il problema non è lì, quanto piuttosto che, avviando da usb, i moduli nell'initrd non vengono caricati correttamente. Alcuni falliscono (tipo jdb2 ed ext4),
Come l'hai generato l'initrd?
Cioè, che passaggi hai fatto?

susumella
Linux 2.x
Linux 2.x
Messaggi: 442
Iscritto il: mar 25 mag 2004, 0:00

Re: NVME usb non riconosciuto

Messaggio da susumella »

Disco montato all'interno e /usr/share/mkinitrd/mkinitrd_command_generator.sh
Per adesso va bene così... nel weekend basta ed avanza avere il mio disco nel laptop aziendale, durante la settimana è difficile che ne abbia bisogno.
Grazie ancora!

rik70
Iper Master
Iper Master
Messaggi: 2365
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 4.19
Desktop: Sway
Distribuzione: Arch Linux

Re: NVME usb non riconosciuto

Messaggio da rik70 »

susumella ha scritto:
sab 16 apr 2022, 17:09
Disco montato all'interno e /usr/share/mkinitrd/mkinitrd_command_generator.sh
Per quello che non va via usb.
L'unico modo per generare un initrd valido che ti permetta di fare il boot via usb del disco in questione è stato accennato sopra.

Oh beninteso: io mi limito a rispondere all'argomento del titolo.
Se poi uno trova una soluzione che non ha nulla a che vedere, buon per lui ma non mi riguarda 8)

Rispondi