pdfgrep e POPPLER su chroot e non

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
conraid
Staff
Staff
Messaggi: 13601
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

pdfgrep e POPPLER su chroot e non

Messaggio da conraid »

Mi succede una cosa strana. Ricompilo pdfgrep in chroot e ok, compila e funziona.
ldd di pdfgrep mio da questo:

Codice: Seleziona tutto

CHROOT-CURRENT-root@thinkstar1:/tmp ldd pdfgrep 
        linux-vdso.so.1 (0x00007ffc56362000)
        libpoppler-cpp.so.0 => /usr/lib64/libpoppler-cpp.so.0 (0x00007f2085d5c000)
        libpcre.so.1 => /lib64/libpcre.so.1 (0x00007f2085ce4000)
        libgcrypt.so.20 => /lib64/libgcrypt.so.20 (0x00007f2085ba1000)
        libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007f2085b79000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f2085966000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f2085882000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f2085866000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f208564c000)
        libpoppler.so.120 => /usr/lib64/libpoppler.so.120 (0x00007f20852c1000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f20852bc000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f2085dac000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f20851f5000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f20851ac000)
        libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x00007f2085103000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f20850e9000)
        libcurl.so.4 => /usr/lib64/libcurl.so.4 (0x00007f2085046000)
        libopenjp2.so.7 => /usr/lib64/libopenjp2.so.7 (0x00007f2084fe4000)
        liblcms2.so.2 => /usr/lib64/liblcms2.so.2 (0x00007f2084f82000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007f2084f4c000)
        libtiff.so.5 => /usr/lib64/libtiff.so.5 (0x00007f2084ec5000)
        libnss3.so => /usr/lib64/libnss3.so (0x00007f2084d91000)
        libsmime3.so => /usr/lib64/libsmime3.so (0x00007f2084d67000)
        libplc4.so => /usr/lib64/libplc4.so (0x00007f2084d60000)
        libnspr4.so => /usr/lib64/libnspr4.so (0x00007f2084d1f000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x00007f2084d0c000)
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007f2084c01000)
        libbrotlidec.so.1 => /usr/lib64/libbrotlidec.so.1 (0x00007f2084bf4000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f2084a86000)
        libcares.so.2 => /usr/lib64/libcares.so.2 (0x00007f2084a6e000)
        libnghttp2.so.14 => /usr/lib64/libnghttp2.so.14 (0x00007f2084a42000)
        libidn2.so.0 => /usr/lib64/libidn2.so.0 (0x00007f2084a20000)
        libssh2.so.1 => /usr/lib64/libssh2.so.1 (0x00007f20849de000)
        libpsl.so.5 => /usr/lib64/libpsl.so.5 (0x00007f20849cb000)
        libssl.so.1.1 => /lib64/libssl.so.1.1 (0x00007f2084935000)
        libcrypto.so.1.1 => /lib64/libcrypto.so.1.1 (0x00007f2084650000)
        libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x00007f20845fe000)
        libldap.so.2 => /usr/lib64/libldap.so.2 (0x00007f208459c000)
        liblber.so.2 => /usr/lib64/liblber.so.2 (0x00007f208458a000)
        libzstd.so.1 => /lib64/libzstd.so.1 (0x00007f20844cc000)
        libwebp.so.7 => /usr/lib64/libwebp.so.7 (0x00007f208445e000)
        liblzma.so.5 => /lib64/liblzma.so.5 (0x00007f2084436000)
        libnssutil3.so => /usr/lib64/libnssutil3.so (0x00007f2084404000)
        libplds4.so => /usr/lib64/libplds4.so (0x00007f20843fd000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007f20843d4000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f20842a0000)
        libbrotlicommon.so.1 => /usr/lib64/libbrotlicommon.so.1 (0x00007f208427d000)
        libunistring.so.2 => /usr/lib64/libunistring.so.2 (0x00007f20840fa000)
        libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00007f2084021000)
        libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00007f2083ff3000)
        libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007f2083fed000)
        libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00007f2083fde000)
        libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007f2083fd7000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f2083fc4000)
        libnsl.so.2 => /lib64/libnsl.so.2 (0x00007f2083fa8000)
        libsasl2.so.3 => /usr/lib64/libsasl2.so.3 (0x00007f2083f8a000)
        libtirpc.so.3 => /lib64/libtirpc.so.3 (0x00007f2083f5a000)
lo installo sulla distro normale e non va cercando una libreria diversa di poppler, e cercando molte meno librerie

Codice: Seleziona tutto

root@thinkstar1:/tmp ldd pdfgrep 
        linux-vdso.so.1 (0x00007ffc3cb8d000)
        libpoppler-cpp.so.0 => /usr/lib64/libpoppler-cpp.so.0 (0x00007f90c5cdd000)
        libpcre.so.1 => /lib64/libpcre.so.1 (0x00007f90c5c65000)
        libgcrypt.so.20 => /lib64/libgcrypt.so.20 (0x00007f90c5b22000)
        libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007f90c5afa000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f90c58e7000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f90c5803000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f90c57e7000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f90c55cd000)
        libpoppler.so.116 => not found
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f90c55c8000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f90c5d39000)

il file è ESATTAMENTE lo stesso, pescano dalla stessa posizione del filesystem

Tra l'altro compilandolo nella distro normale non compila, da questo errore:

Codice: Seleziona tutto

/usr/bin/ld: warning: libpoppler.so.116, needed by /usr/lib64/libpoppler-cpp.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /usr/lib64/libpoppler-cpp.so: undefined reference to `NetPBMWriter::NetPBMWriter(NetPBMWriter::Format)'
/usr/bin/ld: /usr/lib64/libpoppler-cpp.so: undefined reference to `GlobalParamsIniter::~GlobalParamsIniter()'
/usr/bin/ld: /usr/lib64/libpoppler-cpp.so: undefined reference to `TextWordList::~TextWordList()'
/usr/bin/ld: /usr/lib64/libpoppler-cpp.so: undefined reference to `OutlineItem::getKids()'
come vedete qui cerca .so.116

quel warning non compare mai in chroot.

Che BEEP può essere?


p.s.
tutti gli altri software che dipendono da poppler non hanno questo problema

Avatar utente
conraid
Staff
Staff
Messaggi: 13601
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: pdfgrep e POPPLER su chroot e non

Messaggio da conraid »

Guardando bene ho visto che il warning era /usr/lib64/libpoppler-cpp.so
e controllando sembra che fosse rimasta dal vecchio poppler
slackpkg reinstall poppler e tutto è tornato a funzionare in modo normale
Ma strano che il pacchetto non abbia sovrascritto quel file (o altri, non saprei)

Rispondi