Ho cancellato la directory /tmp/

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Sh4DoW
Linux 1.x
Linux 1.x
Messaggi: 155
Iscritto il: mar 15 feb 2005, 0:00

Ho cancellato la directory /tmp/

Messaggio da Sh4DoW »

non so perchè, in un attimo di pazzia.. ho cancellato la directory /tmp...
ora non mi parte più nessun windows manager se non fluxbox.. dal quale sto postando. Questo è quello che mi da quando faccio partire startx (modificando con xwmconfig e scegliendo o kde o xfce):

X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.4.29 i686 [ELF]
Current Operating System: Linux Mithril 2.6.10 #1 Sat Jan 22 12:49:12 PST 2005 i686
Build Date: 23 January 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 21 13:23:36 2005
(==) Using config file: "/etc/X11/xorg.conf"

Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi:unscaled, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/cyrillic, removing from list!
xset: bad font path element (#141), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
startkde: Starting up...
mkdir: Owner of /tmp/.ICE-unix should be set to root
kbuildsycoca running...
SetClientVersion: 0 8
kdecore (KLibLoader): WARNING: KLibrary: /opt/kde/lib/kde3/kcm_kdnssd.so: undefined symbol: init_kdnssd
_IceTransmkdir: ERROR: Owner of /tmp/.ICE-unix must be set to root
_IceTransSocketUNIXCreateListener: mkdir(/tmp/.ICE-unix) failed, errno = 1
_IceTransMakeAllCOTSServerListeners: failed to create listener for local
KSMServer: Error listening for connections: Cannot establish any listening sockets
KSMServer: Aborting.
startkde: Shutting down...
klauncher: Exiting on signal 1
DCOP Cleaning up dead connections.
ICE default IO error handler doing an exit(), pid = 4639, errno = 0
startkde: Running shutdown scripts...
startkde: Done.

waiting for X server to shut down

PLEASE HELP ME

meritil
Master
Master
Messaggi: 1651
Iscritto il: mar 24 ago 2004, 0:00
Slackware: bluewhite64
Contatta:

Messaggio da meritil »

vabbè prima di tutto ricreala.. dopodichè assegnale i permessi giusti

chown root.root /tmp

chmod 777 /tmp

Per il contenuto non preoccuparti io la svuoto tranquillamente di tanto in tanto..

Avatar utente
gallows
Staff
Staff
Messaggi: 3471
Iscritto il: lun 20 set 2004, 0:00
Desktop: cwm
Distribuzione: OpenBSD
Località: ~/
Contatta:

Messaggio da gallows »

prova con:

Codice: Seleziona tutto

# [ ! -e /tmp/.X11-unix ] && mkdir -p /tmp/.X11-unix
# [ ! -e /tmp/.ICE-unix ] && mkdir -p /tmp/.ICE-unix
# chmod 1777 /tmp
# chmod 1777 /tmp/.*-unix 

Avatar utente
zzt
Linux 2.x
Linux 2.x
Messaggi: 249
Iscritto il: lun 7 mar 2005, 0:00

Messaggio da zzt »

inizia fare quello che c'è scritto qui
_IceTransmkdir: ERROR: Owner of /tmp/.ICE-unix must be set to root
metti root come owner

tutti contemporanei... :wink:

Avatar utente
Sh4DoW
Linux 1.x
Linux 1.x
Messaggi: 155
Iscritto il: mar 15 feb 2005, 0:00

Messaggio da Sh4DoW »

Ho fatto quello scritto nei primi 2 post.. e non è cambiato nulla..
per quanto riguarda mettere root come Owner come si fa??

Avatar utente
zzt
Linux 2.x
Linux 2.x
Messaggi: 249
Iscritto il: lun 7 mar 2005, 0:00

Messaggio da zzt »

se hai fatto quello che dice gallows è già ok... comunque

Codice: Seleziona tutto

chown root.root /tmp/.ICE-unix
da root ovviamente...

Avatar utente
Sh4DoW
Linux 1.x
Linux 1.x
Messaggi: 155
Iscritto il: mar 15 feb 2005, 0:00

Messaggio da Sh4DoW »

lo avevo fatto.. ma solo con il comando di adesso... rifunziona tutto...
VI AMO... siamo la miglior comunità di internet... GRAZIE ANCORA.

Avatar utente
zzt
Linux 2.x
Linux 2.x
Messaggi: 249
Iscritto il: lun 7 mar 2005, 0:00

Messaggio da zzt »

Sh4DoW ha scritto: VI AMO... siamo la miglior comunità di internet... GRAZIE ANCORA.
...diciamo che io ti apprezzo... :wink:

Avatar utente
Sh4DoW
Linux 1.x
Linux 1.x
Messaggi: 155
Iscritto il: mar 15 feb 2005, 0:00

Messaggio da Sh4DoW »

ahahahahahhah :D :D :D

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Messaggio da phobos3576 »

Sarebbe utile però approfondire il problema, veramente, serio, della directory /tmp di Linux; in questa directory si trovano importantissimi file di sistema di KDE, Gnome, etc, ma viene usata anche da molte applicazioni come se fosse una vera e propria "discarica di rifiuti" (ad esempio, le anteprime create da Gimp per le immagini).
Nel mio caso, mi sono ritrovato con circa 30000 file (e non sto scherzando) che occupavano quasi 1 Gb; purtroppo, nessuna applicazione che usa /tmp offre un metodo per effettuare la "pulizia". Di conseguenza, l'utente prova a cancellare manualmente i file apparentemente inutili e inesorabilmente provoca un disastro!

Avatar utente
gallows
Staff
Staff
Messaggi: 3471
Iscritto il: lun 20 set 2004, 0:00
Desktop: cwm
Distribuzione: OpenBSD
Località: ~/
Contatta:

Messaggio da gallows »

se la cancelli allo shutdown non avrai problemi, garantito.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Messaggio da phobos3576 »

gallows ha scritto:se la cancelli allo shutdown non avrai problemi, garantito.
Ma ne sei sicuro ?

Le directory come /tmp/kde-root e /tmp/kde-utente non possono essere cancellate, altrimenti si verificano seri problemi con KDE!

Avatar utente
gallows
Staff
Staff
Messaggi: 3471
Iscritto il: lun 20 set 2004, 0:00
Desktop: cwm
Distribuzione: OpenBSD
Località: ~/
Contatta:

Messaggio da gallows »

phobos3576 ha scritto:
gallows ha scritto:se la cancelli allo shutdown non avrai problemi, garantito.
Ma ne sei sicuro ?

Le directory come /tmp/kde-root e /tmp/kde-utente non possono essere cancellate, altrimenti si verificano seri problemi con KDE!
ovviamente se lo fai con kde avviato ci saranno grane, ma se metti "rm -rf /tmp" in rc.6 non avrai alcun problema.

ps. che se ne fa il root di kde? :twisted:

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Messaggio da phobos3576 »

gallows ha scritto:
phobos3576 ha scritto:
gallows ha scritto:se la cancelli allo shutdown non avrai problemi, garantito.
Ma ne sei sicuro ?

Le directory come /tmp/kde-root e /tmp/kde-utente non possono essere cancellate, altrimenti si verificano seri problemi con KDE!
ovviamente se lo fai con kde avviato ci saranno grane, ma se metti "rm -rf /tmp" in rc.6 non avrai alcun problema.

ps. che se ne fa il root di kde? :twisted:
Mi riferivo alla directory /tmp/kde-root che KDE crea per l'utente root (o alla directory /tmp/kde-pippo che KDE crea per l'utente pippo); tempo fa avevo cancellato queste directory ed avevo avuto dei problemi con KDE.

Comunque, adesso provo la procedura che mi hai suggerito!

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio 8 gen 2004, 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Messaggio da navajo »

ragazzi.............. si vede che seguite poco il sito...
scherzo naturalmente. :D ma vi ricordo che ho crato uno scritpino che fa la pulizia di kde alla sua uscita.
http://www.slacky.it/download/traverse. ... pulire-kde
con questo pulirete anche i form.

Rispondi