Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
Moderatore: Staff
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
Ho già messo un messaggio in un topic sull´argomento, ma magari risulterà poco leggibile quindi non vi arrabbiate se posto direttamente un nuovo messaggio.
<BR>
<BR>Ho seguito passo passo l´how to per la compilazione del 2.6.7, non è stato difficile tranne che...
<BR>
<BR>Kernel panic: VFS: Unable to mount root fs on hda2
<BR>
<BR>Avevo configurato lilo in modo da poter partire comunque con il 2.4 che non mi da problemi.
<BR>Ho ricontrollato l´how to e c´è una cosa che non mi convince:
<BR>
<BR>
<BR>"...e poi inserite in /etc/fstab (mantenendo la giusta formattazione) una riga come questa
<BR>
<BR>none /sys sysfs defaults 0 0 "
<BR>
<BR>cosa significa "mantenendo la giusta formattazione"
<BR>per cso non basta aggiungere la riga su scritta? O la riga non va presa alla lettera ma con parametri relativi alla propria configurazione?
<BR>
<BR>
<BR>so già che sarà stato un mio errore del cavolo ma sono un iper neofita e vorrei capirci qualcosa...
<BR>che posso fare?
<BR>Grazie da ora se mi rispondete...
<BR>
<BR><BR><BR>[ Questo Messaggio è stato Modificato da: foo il 03-10-2004 17:07 ]<br>
<BR>
<BR>Ho seguito passo passo l´how to per la compilazione del 2.6.7, non è stato difficile tranne che...
<BR>
<BR>Kernel panic: VFS: Unable to mount root fs on hda2
<BR>
<BR>Avevo configurato lilo in modo da poter partire comunque con il 2.4 che non mi da problemi.
<BR>Ho ricontrollato l´how to e c´è una cosa che non mi convince:
<BR>
<BR>
<BR>"...e poi inserite in /etc/fstab (mantenendo la giusta formattazione) una riga come questa
<BR>
<BR>none /sys sysfs defaults 0 0 "
<BR>
<BR>cosa significa "mantenendo la giusta formattazione"
<BR>per cso non basta aggiungere la riga su scritta? O la riga non va presa alla lettera ma con parametri relativi alla propria configurazione?
<BR>
<BR>
<BR>so già che sarà stato un mio errore del cavolo ma sono un iper neofita e vorrei capirci qualcosa...
<BR>che posso fare?
<BR>Grazie da ora se mi rispondete...
<BR>
<BR><BR><BR>[ Questo Messaggio è stato Modificato da: foo il 03-10-2004 17:07 ]<br>
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
Hai problemi al file system.
<BR>Te lo dice l´errore del kernel panic.
<BR>Quindi devi ricompilare il kernel controllando la sezione file system.
<BR>Controlla nel config del 2.4 come è impostato e copia i settaggi nel 2.6
<BR>Controlla pure nella sezione device se il chipset DMA ecc sono correttamente selezionati.
<BR>Ciao<br>
<BR>Te lo dice l´errore del kernel panic.
<BR>Quindi devi ricompilare il kernel controllando la sezione file system.
<BR>Controlla nel config del 2.4 come è impostato e copia i settaggi nel 2.6
<BR>Controlla pure nella sezione device se il chipset DMA ecc sono correttamente selezionati.
<BR>Ciao<br>
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
ciao, ho avuto anch´io lo stesso problema quando ho cambiato il kernel ma ho risolto senza ricompilarlo creando il file inird.gz (ovviamente non vedeva la partizione di root perchè era reiserfs).
<BR>Se anche te usi reiserfs prova afare così:
<BR>
<BR># mkinitrd -c -k 2.6.7 -m reiserfs
<BR>
<BR>questo ti crea nella directory /boot il file initrs.gz
<BR>adesso aggiungi in /etc/lilo.conf tra le stringhe di inizializzazione della slack con il nuovo kernel la seguente striga:
<BR>
<BR>initrd = /boot/initrd.gz
<BR>
<BR>dopo aver salvato il file lilo.conf lancia "lilo -t" e se non da errori lancia "lilo -v" per scrivere le modifiche nel MBR
<BR>
<BR>riavvia e, se il problema era quello, il sistema dovrebbe partire senza problemi.
<BR>
<BR>
<BR>ciao
<BR>Simone
<BR>
<br>
<BR>Se anche te usi reiserfs prova afare così:
<BR>
<BR># mkinitrd -c -k 2.6.7 -m reiserfs
<BR>
<BR>questo ti crea nella directory /boot il file initrs.gz
<BR>adesso aggiungi in /etc/lilo.conf tra le stringhe di inizializzazione della slack con il nuovo kernel la seguente striga:
<BR>
<BR>initrd = /boot/initrd.gz
<BR>
<BR>dopo aver salvato il file lilo.conf lancia "lilo -t" e se non da errori lancia "lilo -v" per scrivere le modifiche nel MBR
<BR>
<BR>riavvia e, se il problema era quello, il sistema dovrebbe partire senza problemi.
<BR>
<BR>
<BR>ciao
<BR>Simone
<BR>
-
samiel
- Staff

- Messaggi: 5511
- Iscritto il: ven 16 gen 2004, 0:00
- Nome Cognome: Mauro Sacchetto
- Slackware: 13.0
- Kernel: 2.26
- Desktop: KDE
- Distribuzione: anche Debian
- Località: Venezia
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
Certo, initrd, ma senza tante complicazioni
<BR>non basta ricordarsi di selezionarlo
<BR>staticamente e non come modulo nel kerne?
<BR>
<BR>M.<br>
<BR>non basta ricordarsi di selezionarlo
<BR>staticamente e non come modulo nel kerne?
<BR>
<BR>M.<br>
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
Certo che è meglio selezionarlo staticamente, sono daccordissimo con te, ma solo se ricompili e quindi ce lo butti dentro, se tutto il resto del sistema funziona bene o se usi i kernel precompilati forniti nel cd di installazione non vale la pena di fare una ricompilazione solo per questo.
<BR>Ma questa è solo una mia opinione
<BR>
<BR>ciao
<BR>Simone<br>
<BR>Ma questa è solo una mia opinione
<BR>
<BR>ciao
<BR>Simone<br>
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
Ti rispondo per "la giusta formattazione". Devi scrivere la riga separando al bisogno le parole con lo spazio dato dal tasto TAB...tutto qui ...
<BR>Ciao<br>
<BR>Ciao<br>
- useless
- Staff

- Messaggi: 3896
- Iscritto il: dom 12 ott 2003, 0:00
- Località: A place where the streets have no name
- Contatta:
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
giusto, ma anche un banale spazio va benissimo in realtà
.<br>
Kernel panic (dopo aggiornamento a 2.6.7), siate pazienti...
non so voi...ma il mio fstab e´ formattato malissimo pieno di sharp e di spazi e funziona benissimo<br>


