Configurare PHP + APACHE + MYSQL

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Configurare PHP + APACHE + MYSQL

Messaggio da sonzo »

ragazzi, ho scaricato i packeges di php apache e mysql.

Pero' non riesco a visualizzare i files php, o meglio vedo solo il sorgente del php e non mi interpreta il linguaggio.

Ho configurato httpd.conf inserendo queste stringhe:

LoadModule php5_module /usr/lib/apache2/libphp5.so

AddType application/x-httpd-php .php

libphp5.so si trova in quella dir, l'ho trovata con un FIND :D

Ma nonostante tutto non va e non capisco come mai!!!!!

Io ho provato anche a fare un apachectl stop

Se pero' faccio un http://127.0.0.1 vedo la mia pagina html.
Come mai? teoricamente non dovrebbe non vedersi visto che è bloccato il server?

Boh.. sono nelle vostre mani grazie!!

Ciao.

sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Messaggio da sonzo »

Io ho provato anche a fare un apachectl stop

Se pero' faccio un http://127.0.0.1 vedo la mia pagina html.
Come mai? teoricamente non dovrebbe non vedersi visto che è bloccato il server?
Niente lasaciate perdere questo perchè... ho cancellato la cache del browser e ora va tutto bene ;)

Comunque il problema del php rimane!
:D
A presto

Avatar utente
airex
Linux 1.x
Linux 1.x
Messaggi: 121
Iscritto il: sab 8 lug 2006, 11:03
Slackware: -current
Desktop: xfce
Distribuzione: Slackware64
Località: Milano
Contatta:

Messaggio da airex »

la pagina php che vuoi "vedere" ha l'estensione .php vero?
Intanto che ci sei controlla cosa dicono i file di log di apache, spesso se ci sono problemi li qualcosa viene detto :wink:

Avatar utente
manolo
Linux 2.x
Linux 2.x
Messaggi: 282
Iscritto il: gio 26 mag 2005, 0:00
Desktop: kde

Messaggio da manolo »

Hai abilitato php in apache.conf?

Avatar utente
Darathorn
Linux 2.x
Linux 2.x
Messaggi: 315
Iscritto il: dom 28 nov 2004, 0:00
Nome Cognome: Francesco Braga
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: fluxbox
Località: Rezzato
Contatta:

Messaggio da Darathorn »

hai aggiunto index.php in directoryindex ?

sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Messaggio da sonzo »

Ragazzi risolto, prima non mi dava Powered By PHP ora si!

Ma nonostante questo non va comunque :(

Vi posto qualche output:

# telnet 127.0.0.1 80
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
HEAD / HTTP/1.0

HTTP/1.1 200 OK
Date: Mon, 10 Jul 2006 09:17:35 GMT
Server: Apache/2.0.58 (Unix) DAV/2 PHP/5.1.4
X-Powered-By: PHP/5.1.4
Connection: close
Content-Type: text/html

Connection closed by foreign host.

Quindi sembra OK. Gli error sono:

# tail error_log
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_firebird.so' - libfbclient.so.1: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_odbc.so' - libodbc.so.1: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_pgsql.so' - libpq.so.4: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_sqlite.so' - libsqlite3.so.0: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pgsql.so' - libpq.so.4: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/sqlite.so' - libsqlite.so.0: cannot open shared object file: No such file or directory in Unknown on line 0
[Mon Jul 10 10:27:52 2006] [notice] Apache/2.0.58 (Unix) DAV/2 PHP/5.1.4 configured -- resuming normal operations
[Mon Jul 10 10:28:21 2006] [error] [client 127.0.0.1] File does not exist: /var/www/htdocs/favicon.ico
[Mon Jul 10 10:28:27 2006] [error] [client 127.0.0.1] File does not exist: /var/www/htdocs/favicon.ico
[Mon Jul 10 10:28:31 2006] [error] [client 127.0.0.1] File does not exist: /var/www/htdocs/favicon.ico

Che dite ? sembra ok.

Provate a dirmi cosa avete voi nel vs file httpd.conf!
Che mi dite? COnsigli? Opinioni?

Ciao

sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Messaggio da sonzo »

Ops dimenticavo.. sembra OK.. beh tranne gli errori di PHP.

Come mai quegli errori? Che devo fare?

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4623
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 5.4.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Messaggio da aschenaz »

Se non ti serve proprio il php5, io, al posto tuo, disinstallerei tutto e installerei Apache, Php e MySql dal cd di slackware 10.2. Così sei sicuro che funziona.
Scusa la soluzione un po' spartana... :)
Ciao,
nino

sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Messaggio da sonzo »

Uhm.. ma da CD? con cosa? Installpkg?

Io volevo provare così!!!!!

Che mi dite?

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4623
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 5.4.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Messaggio da aschenaz »

sonzo ha scritto:Uhm.. ma da CD? con cosa? Installpkg?
Proprio così!
Dal primo CD:
MySql sta nella directory ap;
Apache e PHP stanno nella directory n.
Ciao,
nino

sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Messaggio da sonzo »

uhm.. scusa l'ignoranza avvio il CD
e poi entro via shell come # e faccio un installpkg?

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4623
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 5.4.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Messaggio da aschenaz »

sonzo ha scritto:... avvio il CD
e poi entro via shell come # e faccio un installpkg?
Si:
prima, però, disinstalla i pacchetti che hai installato (con removepkg),
poi monta il cd,
diventa root e

Codice: Seleziona tutto

installpkg /mnt/cdrom/slackware/ap/mysql-[versione].tgz...
Fa' lo stesso con Apache e Php.

Ciao,
nino

sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Messaggio da sonzo »

Ho fatto, rimosso i pacchetti e tutto.. ma niente non gira. Ho inserito i LoadModules etc etc ma niente mi dice che non trova alcuni moduli. Come mai??????

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4623
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 5.4.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Messaggio da aschenaz »

sonzo ha scritto:Ho fatto, rimosso i pacchetti e tutto.. ma niente non gira. Ho inserito i LoadModules etc etc ma niente mi dice che non trova alcuni moduli. Come mai??????
Apache parte?
Che moduli non trova?

sonzo
Linux 0.x
Linux 0.x
Messaggi: 91
Iscritto il: mer 8 feb 2006, 17:59

Messaggio da sonzo »

Grazie per tutto ragazzi....

Ho risolto installando la versione 2 di Apache e la 5; che fino a 2 giorni fa non andava..

Sono stato ore sul file httpd.conf etc etc... Mi sono rotto il cranio e ho risolto.

Ho rimossi i pacchetti, e li ho reinstallati e ora sembra andare tutto.

Ringrazio.

Ciao

Rispondi