ho un problema che non riesco a capire;
ho dovuto cambiare hdd ora ne ho uno serial
ATA, ho quindi usato il kernel sata.i per
avviare l'istallazione di slack. Tutto ok
per quanto riguarda l'istallazione ma appena
compilo il kernel e creo l'immagine bzImage
del kernel compilato come serve a me all'avvio
mi da un kernel panic, fortunatamente posso
comunque accedere perchè il mio lilo.conf è
così costituito
Codice: Seleziona tutto
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda7
label = slackware
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
image = /boot/bzImage
root = /dev/sda7
label = slackware_neu
read-only # Non-UMSDOS filesystems should be mounted read-only for #checking
# Linux bootable partition config endstutto funge perfettamente, ma ovviamente non
è tutto configurato per benino, o meglio la
sola cosa che non riesco a configurare è il
modulo apm, se modifico la stringa dedicata al
modulo in /etc/rc.d/rc.modules al riavvio ho
in risposta questo
Codice: Seleziona tutto
/lib/modules/2.4.31/kernel/arch/i386/kernel/apm.o.gz: init_module: No such device
/lib/modules/2.4.31/kernel/arch/i386/kernel/apm.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.31/kernel/arch/i386/kernel/apm.o.gz: insmod /lib/modules/2.4.31/kernel/arch/i386/kernel/apm.o.gz failed
/lib/modules/2.4.31/kernel/arch/i386/kernel/apm.o.gz: insmod apm failedquesto mi accadeva anche con la vecchia
istallazione su hdd IDE, risolvevo creando
bzImage dove apm non era modulare, ma usando
il sata.i (credo sia questo il problema)
ottengo il kernel panic.
Soluzioni?



