kernel panic..perchè?

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Ermes1
Linux 2.x
Linux 2.x
Messaggi: 374
Iscritto il: sab 25 mar 2006, 16:45

kernel panic..perchè?

Messaggio da Ermes1 »

salve a tutti. ho bisogno di un aiuto: l'altro giorno ho installato slack 11 su un pc. l'ho installata innanzitutto col kernel di default 2.4.33.3 su fs reisers. e funzionava bene. poi ho deciso di installare il kernel 2.6.17.13. l'ho fatto dai pacchetti precompilati ma quando vado ad avviarla ho il seguente messaggio:

no filesystem could mount root, tried : ext2
kernel panic - not syncing : vfs : unable to mount root fs on unknown block(3,6)

che significa? come risolvo?

samiel
Staff
Staff
Messaggi: 5511
Iscritto il: ven 16 gen 2004, 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

Messaggio da samiel »

Verosimilmente significa che hai tralasciato di creare l'initrd.
Vedi le indicazioni in S4d, § 19.1.1

M.

Ermes1
Linux 2.x
Linux 2.x
Messaggi: 374
Iscritto il: sab 25 mar 2006, 16:45

Messaggio da Ermes1 »

si è probabile in effetti non l'ho fatto: non mi sono mai rovato a dover installare / su reiser.

bene ora funziona era quello!! comunque ho delle domande ora!!

sempre su S4D c'è scritto che è non è consigliabile installare anche gli headers, ma se non li si installa quelli del 2.4 possono creare problemi?

poi vorrei segnalare degli errori su S4D.

1)reiserfs è scritto con la maiuscola (il che porta all'errore utenti niubbi come me) :D

2)nel esempio in cui si mostra come creare l'initrd per reiserfs c'è il kernel 2.6.10 invece che 2.6.17.13

3)infine sempre in quell'esempio c'è scritto /dev/hdan invece di /dev/hdxn

spero di essere stato utile!! devo avvertire qualcuno di persona?

grazie mille comunque!

samiel
Staff
Staff
Messaggi: 5511
Iscritto il: ven 16 gen 2004, 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

Messaggio da samiel »

Per gli headers,vale la regola di mantenere quelli
con cui sono state compilate le glibc. Per cui
meglio mantenere quelli del 2.4. Salvo casi particolari
di pacchetti che richiedono il 2.6, tutto funziona bene,
anzi meglio, perché alcuni pacchetti non aggiornatissimi
invece non compilano ancora col 2.6.

Per gli errori, grazie della segnalazione, adesso verifico.
Dovevi avvertire me, e lo hai fatto.... :-)

M.

Ermes1
Linux 2.x
Linux 2.x
Messaggi: 374
Iscritto il: sab 25 mar 2006, 16:45

Messaggio da Ermes1 »

eccellente... ciao :D :D

Rispondi