Directory sempre con Permission Denied...

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
cWrite
Linux 1.x
Linux 1.x
Messaggi: 152
Iscritto il: sab 6 mag 2006, 10:24
Slackware: 12.0
Località: Provincia di Milano

Directory sempre con Permission Denied...

Messaggio da cWrite »

Ciao a tutti, ho un problema con una Directory come da titolo.
Sono sullo StoreShare aziendale e c'è una directory normalissima che pero non si fa cancellare.

Do qualche spiegazione:

Tramite Konsole se mi porto al termine delle Sottodirectory della folder in questione (../DirectoryIncriminata../../../..) riscontro un errore quando digito ls, la konsole mi da in output un messaggio:
root@StoreShare:/storeshare/unbackupped# ls BackupMilella/Disco\ D/zip1/PERSONALE/
/usr/bin/ls: BackupMilella/Disco D/zip1/PERSONALE/suddivisionedel personalecc.xls: Permission denied
/usr/bin/ls: BackupMilella/Disco D/zip1/PERSONALE/TFR AL 300906.doc: Permission denied
/usr/bin/ls: BackupMilella/Disco D/zip1/PERSONALE/trasferteMinFinanzeCircolare326.doc: Permission denied
/usr/bin/ls: BackupMilella/Disco D/zip1/PERSONALE/treviglio 007_edited.jpg: Permission denied
/usr/bin/ls: BackupMilella/Disco D/zip1/PERSONALE/treviglio 007.jpg: Permission denied
/usr/bin/ls: BackupMilella/Disco D/zip1/PERSONALE/treviglio 008.jpg: Permission denied
/usr/bin/ls: BackupMilella/Disco D/zip1/PERSONALE/treviglio 009.jpg: Permission denied
Alchè ho pensato fosse semplicemente un problema di permessi..nonostante io fossi gia in root, ma comunque ho ridefinito i permessi per l'intera directory pero cosi facendo ricevo la solita risposta...
root@StoreShare:/storeshare/unbackupped# ls -lh BackupMilella/
total 512
drwxr-xr-x 3 root root 72 2007-09-04 15:57 Disco\ D/

root@StoreShare:/storeshare/unbackupped# rm -rf BackupMilella/
rm: cannot remove `BackupMilella//Disco D/zip1/PERSONALE/suddivisionedel personalecc.xls': Permission denied
rm: cannot remove `BackupMilella//Disco D/zip1/PERSONALE/TFR AL 300906.doc': Permission denied
rm: cannot remove `BackupMilella//Disco D/zip1/PERSONALE/trasferteMinFinanzeCircolare326.doc': Permission denied
rm: cannot remove `BackupMilella//Disco D/zip1/PERSONALE/treviglio 007_edited.jpg': Permission denied
rm: cannot remove `BackupMilella//Disco D/zip1/PERSONALE/treviglio 007.jpg': Permission denied
rm: cannot remove `BackupMilella//Disco D/zip1/PERSONALE/treviglio 008.jpg': Permission denied
rm: cannot remove `BackupMilella//Disco D/zip1/PERSONALE/treviglio 009.jpg': Permission denied
...fatto uesto e altre prove comuqnue inerenti al maneggiare i permessi no nsono ancora riuscito a eliminare la folder...da cosa puo dipendere tale problema e come si puo risolvere soprattutto?

Ciao e grazie per gli eventuali aiuti.
Ultima modifica di cWrite il lun 21 gen 2008, 15:12, modificato 1 volta in totale.

sixjan
Linux 2.x
Linux 2.x
Messaggi: 413
Iscritto il: dom 6 gen 2008, 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: Directory sempre con Permission Denied...

Messaggio da sixjan »

Ciao. Hai cambiato i permessi ricorsivamente a tutto il contenuto o solo alla directory?
Se apri il pannello Proprietà di uno di quei file jpg con Konqueror, cosa ti dice a proposito di proprietario e permessi? La directory è nella stassa partizione del sistema in uso o è una prtizione montata? Ciao.

EDIT:

Ho visto che hai aggiunto delle note; per caso il disco D è un disco con partizione ntfs?

Avatar utente
cWrite
Linux 1.x
Linux 1.x
Messaggi: 152
Iscritto il: sab 6 mag 2006, 10:24
Slackware: 12.0
Località: Provincia di Milano

Re: Directory sempre con Permission Denied...

Messaggio da cWrite »

Ciao scusa ho modificato il post iniziale inserendo alcuni Output di alcuni comandi.

Comunque io lavoro tramite Putty perche non c'è il monitor nel CED e non abbiamo modo di portarne uno e attaccarlo ora, questa operazione è più che altro un tentativo di rimozione delle directory ormai inutilizzate che dedichiamo nel tempo libero...non so se mi spiego, non è una cosa importantissima pero sai vorrei una risposta soddisfacente.

Chiudendo questa piccola parentesi, ritorno dicendo che lavoro con Putty quindi non ho ambiente grafico... non saprei dirti...come si comporta con konquero, pero posso dirti che con Ubuntu entrando nel dominio e andando a ricercare quella directory e provando a eliminarla ho un messaggio del genere:
Cannot move file to trash, do you want to delete immediatly?
Ovviamente digito su Delete e mi compare questo messaggio:
Error while deleting.
"smb://stor...PERSONALE" cannot be deleted because you do have permissions to modify its parent folder.

Skip Cancel Retry
Inutile qualsiasi tentativo poi, il file non si smuove.

Il disco D risiede nella partizione ext3 di Slackware..è un Backup di un cliente che è stato salvato su Slackware tramite Windows da qualche dipendente. (come del resto moltissimi files in questo disco).

Ciao

sixjan
Linux 2.x
Linux 2.x
Messaggi: 413
Iscritto il: dom 6 gen 2008, 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: Directory sempre con Permission Denied...

Messaggio da sixjan »

cWrite ha scritto:Error while deleting.
"smb://stor...PERSONALE" cannot be deleted because you do have permissions to modify its parent folder.
Qual è la parent folder e a chi appartiene?

Avatar utente
cWrite
Linux 1.x
Linux 1.x
Messaggi: 152
Iscritto il: sab 6 mag 2006, 10:24
Slackware: 12.0
Località: Provincia di Milano

Re: Directory sempre con Permission Denied...

Messaggio da cWrite »

/storeshare/unbackupped/BackupMilella/Disco\ D/zip1/PERSONALE/
drwxrwxrwx 21 root root 704 2008-01-15 12:35 unbackupped/
Più su di cosi non si va... //storeshare è il top

sixjan
Linux 2.x
Linux 2.x
Messaggi: 413
Iscritto il: dom 6 gen 2008, 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: Directory sempre con Permission Denied...

Messaggio da sixjan »

Sicuramente l'hai già fatto:

chown -R root:root storeshare
chmod -R 777 storeshare (se puoi farlo senza far danni)

e poi provare a cancellare.

Avatar utente
cWrite
Linux 1.x
Linux 1.x
Messaggi: 152
Iscritto il: sab 6 mag 2006, 10:24
Slackware: 12.0
Località: Provincia di Milano

Re: Directory sempre con Permission Denied...

Messaggio da cWrite »

Si purtroppo è una soluzione che è gia stata adottata...senza alcun risultato positivo pero.

Avatar utente
conraid
Staff
Staff
Messaggi: 13631
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Directory sempre con Permission Denied...

Messaggio da conraid »

cWrite ha scritto:Si purtroppo è una soluzione che è gia stata adottata...senza alcun risultato positivo pero.
lsattr che ti dice per quei file?

al limite prova a cancellare i file tramite inode

Mario Vanoni
Iper Master
Iper Master
Messaggi: 3174
Iscritto il: lun 3 set 2007, 21:20
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey
Località: Cuasso al Monte (VA)

Re: Directory sempre con Permission Denied...

Messaggio da Mario Vanoni »

cWrite ha scritto:Si purtroppo è una soluzione che è gia stata adottata...senza alcun risultato positivo pero.
Ho un _vago_ ricordo, gia` pensionato, risolto allora via internet (a 300km).

Scenario:
macchina Linux con due HD SCSI
sul primo /home con accesso da
una macchina M$, l'amministratore (sic!)
trasferisce GB sulla Linux
il secondo HD e` backup
ogni giorno /home + dati importanti in *.tar.bz2
la macchina comincia a fare bizze

il secondo HD e` pieno, 0 libero
cancello dal primo HD l'immondizia in /home
cerco di cancellare dal secondo i backup piu` vecchi
non riesco, error messages che non posso
guardo /lost+found, strapieno, idem il /tmp del secondo HD
con find /secondo_disco/tmp -exec rm -f {} \;
mi cancella /secondo_disco/tmp, df lascia sperare
find /secondo_disco/lost+found -exec rm -f {} \;
df, ora si respira meglio
umount il secondo_disco
e2fsck -fy /dev/secondo_disco
interminabile serie di correzioni che fa
mount'o di nuovo il disco
mkdir tmp
chmod 4777 tmp
mklost+found
cancello senza problemi i files incriminati
un altro umount, e2fsck, poi mount di nuovo
et voila`, no problems da >1 anno

Non so se serve, reminiscenze/ricordi ...

Mario Vanoni

PS Il rischo era grande, se reboot'ava a 300km di distanza ...

PS2 L'accesso era con ssh(1) da utente normale, poi /bin/su -,
macchine Linux ambo le parti.

Avatar utente
cWrite
Linux 1.x
Linux 1.x
Messaggi: 152
Iscritto il: sab 6 mag 2006, 10:24
Slackware: 12.0
Località: Provincia di Milano

Re: Directory sempre con Permission Denied...

Messaggio da cWrite »

root@StoreShare:/storeshare/unbackupped# lsattr BackupMilella/
------------- BackupMilella//Disco D
Una cosa che mi fa molto pensare è quel doppio Slash...è un particolare che mi colpisce sempre ogni volta che provo a eliminare la folder...comuqnue all'interno di BackupMilella ci sono altre 3 directory...

Mario Vanoni grazie per la spiegazione ma come detto precedentemente è un lavoro che faccio nel tempo libero per ripulire un po...non posso pero permettermi di rischiare con i file di tutta l'azienda...mi decapiterebbero se qualcosa dovesse andare storto... :)

Avatar utente
conraid
Staff
Staff
Messaggi: 13631
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Directory sempre con Permission Denied...

Messaggio da conraid »

cWrite ha scritto:
root@StoreShare:/storeshare/unbackupped# lsattr BackupMilella/
------------- BackupMilella//Disco D
sui file fallo, non sulle dir sopra.
Metti che per chissà quale motivo sia stato fatto un

Codice: Seleziona tutto

#chattr +i pippo.jpg
Da proprio quell'errore

Avatar utente
cWrite
Linux 1.x
Linux 1.x
Messaggi: 152
Iscritto il: sab 6 mag 2006, 10:24
Slackware: 12.0
Località: Provincia di Milano

Re: Directory sempre con Permission Denied...

Messaggio da cWrite »

Sui file mi da Permission Denied... come con ls...

Avatar utente
conraid
Staff
Staff
Messaggi: 13631
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Directory sempre con Permission Denied...

Messaggio da conraid »

cWrite ha scritto:Sui file mi da Permission Denied... come con ls...
Da root lsattr sul file ti da permissione denied???
E sei fai "ls -i"?

Mario Vanoni
Iper Master
Iper Master
Messaggi: 3174
Iscritto il: lun 3 set 2007, 21:20
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey
Località: Cuasso al Monte (VA)

Re: Directory sempre con Permission Denied...

Messaggio da Mario Vanoni »

cWrite ha scritto:
root@StoreShare:/storeshare/unbackupped# lsattr BackupMilella/
------------- BackupMilella//Disco D
Una cosa che mi fa molto pensare è quel doppio Slash...è un particolare che mi colpisce sempre ogni volta che provo a eliminare la folder...comuqnue all'interno di BackupMilella ci sono altre 3 directory...

Mario Vanoni grazie per la spiegazione ma come detto precedentemente è un lavoro che faccio nel tempo libero per ripulire un po...non posso pero permettermi di rischiare con i file di tutta l'azienda...mi decapiterebbero se qualcosa dovesse andare storto... :)
Usa il suggerimento di conraid:

ls -abilR /directory_incriminata | less oppure
find /directory_incriminata -exec ls -abil {} \; | less
notati la inode di un file che vorresti cancellare
find -inum numero_inode -ls
se trovato, cancellalo con
find -inum numero_inode -exec rm -iv {} \;
# -i ti richiede l'autorizzazione, spesso meglio
# -v ti dice quello che fa/ha fatto

Controlla in ogni caso lost+found,
fa scherzi micidiali se colmo!

Mario Vanoni

Avatar utente
cWrite
Linux 1.x
Linux 1.x
Messaggi: 152
Iscritto il: sab 6 mag 2006, 10:24
Slackware: 12.0
Località: Provincia di Milano

Re: Directory sempre con Permission Denied...

Messaggio da cWrite »

Vi ringrazio gia da ora, domani appena vado in ufficio e appena ho un attimo di tempo libero provo immediatamente i vostri consigli e vi posterò gli Output perchè ora sono a casa e non ho l'ip della macchina per provare da qua...

Vi aggiorno domani in mattinata.

Grazie ancora.

Rispondi